[stunnel-users] stunnel: symbol lookup error: stunnel undefined symbol: X509_check_host

Michal Trojnara Michal.Trojnara at mirt.net
Mon Oct 19 23:23:43 CEST 2015


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 19.10.2015 23:12, Ryan McLeod wrote:
> Once I did that, stunnel installed just fine. But when I run
> stunnel, I get the error in the subject. I tried reinstalling
> stunnel with a configure option: --with-ssl=/usr/local/ssl/. But no
> change.

You compiled stunnel against OpenSSL 1.0.2d, but you are running it
with OpenSSL older than 1.0.2.  You need to configure your dynamic
loader to choose the correct library when running stunnel.

A simple way to do it is:
LD_LIBRARY_PATH=/usr/local/ssl/lib /usr/local/bin/stunnel

Mike
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJWJV9eAAoJEC78f/DUFuAUT8YQAJeU4u7IOaU5l4HOE/34iVkE
MuQLgsdXE+oL5Cn0ItddF9koGBuSOBtT7fxTxn51htXrpgge86SGJqLoNs+ptpN4
0rjRHsHSz3XNbC1tXJLUBLpUNmDHve/Ua76tNqChUr5b1KPwst/qIH+n2/Ps+V0w
iRHDtZb+s+r9AqzFHbQ6+3t4d7SUYMx4exQOD//OSsWOeXP5lX6Hgx+FOmZkwB7R
YDUFcGGRHI989d20elQAuwmGFzGqc2G+UC+us19PFNN9ecjgMyblqpH/fr48SVnc
kNmcS9gGbUK8GnxHSnlXStZ2qtGvhzdSlp8Ez6dZ1yeCYm6bGJUl7yZ2GQLhrzGK
d3BQl6i0QgashuqhvcTIJptliqmmTjokv+bbaAcfY46cmMIs9Ec5f1rYlAAlZb4/
/cX5YcSuyO/9Tp1DowrmgOX/L2gmIQsSFijFiG3QY75GR7EwtkVv+8e2NJwyiIsN
8GtuxipJweMul4xO+bfoQ0YFIjnNzRn+/Q7TnyfPJ3h2EyVjtGs0WPHQXLLSzYCf
DEcwF3IsSTLIUzEiTNLTR+8WJ92j1Mc6YvV++pVsdEFHr0v9kfeSRan55sdD/sum
G1wraJICVF01DeJ8SYMe/Ye3wZ45KKBkCqeCpTdKkcW4F4v6D5Xjd6Em/qmaIc9W
iOOR7RFjDVrzVvnALOtZ
=QDnU
-----END PGP SIGNATURE-----


More information about the stunnel-users mailing list