[stunnel-users] SSH connection problems inside stunnel

David BERCOT debian at bercot.org
Fri Mar 13 08:08:00 CET 2015


Le Thu, 12 Mar 2015 17:59:08 +0100,
David BERCOT <debian at bercot.org> a écrit :
> Le Thu, 12 Mar 2015 15:38:56 +0100,
> debian at bercot.org a écrit :
> > Le 2015-03-12 15:30, Peter Pentchev a écrit :
> > > On Thu, Mar 12, 2015 at 01:28:53PM +0100, debian at bercot.org wrote:
> > >> Hello,
> > >> 
> > >> I've installed a stunnel between my laptop and my server (both
> > >> in Debian
> > >> SID) [v5.06-2].
> > >> 
> > >> Here is my client stunnel.conf :
> > > [snip]
> > >> 
> > >> The server one :
> > > [snip]
> > >> 
> > >> And my .ssh/config :
> > > [snip]
> > >> 
> > >> At home (I use tinyproxy to test), everything is OK. At work,
> > >> with a "true"
> > >> proxy, sometimes I can connect (but I'm quickly disconnected), 
> > >> sometimes I
> > >> can't...
> > >> I've watch the logs but find nothing.
> > >> 
> > >> Do you have any idea ? Something to look in the logs ?
> > > 
> > > Hi,
> > > 
> > > You may be seeing the problem described in Debian bug #771241 -
> > > https://bugs.debian.org/771241 - which was actually fixed in later
> > > upstream versions of Stunnel, but I haven't got around to adding
> > > the fix to the Debian package yet :(  Sorry about that, I'll see
> > > what I can do to prepare an updated package within the next couple
> > > of days.
> > > 
> > > G'luck,
> > > Peter
> > 
> > Well, if it's a bug, it's good news for me ;-)
> > I've seen there is a patch : 
> > 17-upstream-POLLRDHUP-handling-error-fix.patch
> > It is only for the client ?
> > Do you know if I can apply it ?
> > 
> > Thank you.
> > 
> > David.
> 
> Well, I've compiled the last version (5.11) on the client side.
> I will test it tomorrow in order to verify that everything is OK.
> 
> Thank you.
> 
> David.

Hello,

I've tested this morning and everything is OK with 5.11 on the client
side.

David.


More information about the stunnel-users mailing list