[stunnel-users] Bugs

Gonzalo Diethelm gonzalo.diethelm at diethelm.org
Mon Nov 12 15:21:52 CET 2007


A wild guess: is it truncating your "Program Files" path? I don't know
what it is called in German, but "c:\Programme\stunnel" looks too short
to me. Try using quotes, short path names and/or forward slashes instead
of bakslashes.

Best regards.

On Mon, 2007-11-12 at 09:32 +0100, Jan.Haering at rz-kiru.de wrote:

> The second Bug appears also with full specified path. There will be a problem in Version 4.2x > 4.21 to find the log, because this message is not be logged the log-file, only in the Icon log which is not available in 4.21.
> 
> 2007.11.12 08:43:20 LOG3[2696:2700]: c:\Programme\stunnel\logs\stunnel.log: Broken pipe (32)
> 2007.11.12 08:43:20 LOG3[2696:2700]: Unable to open output file: c:\Programme\stunnel\logs\stunnel.log
> 
> Best Regards
> Jan
> 
> 
> -----Urspr√ľngliche Nachricht-----
> Von: stunnel-users-bounces at mirt.net [mailto:stunnel-users-bounces at mirt.net] Im Auftrag von Michal Trojnara
> Gesendet: Freitag, 9. November 2007 22:25
> An: stunnel-users at mirt.net
> Betreff: Re: [stunnel-users] Bugs
> 
> Jan.Haering at rz-kiru.de wrote:
> > 1. In Version 4.21:
> > No Taskbar Icon is displayed when the service starts. Although the 
> > taskbar ist set in config file (taskbar = yes).
> 
> It's not a bug.  It's a feature.  Any object (icon, window, etc.) displayed by a service may be exploited by a local user to gain privileges of this user (in this case usually LocalSystem).
> 
> > 2. In probably all Versions (I have testet 4.18, 4.20 and 4.21) If i 
> > started the service over Start -> Programm Files -> stunnel -> Service 
> > Start (stunnel -start) no log files are written. If i start the 
> > service over services.msc from Windows or "sc start stunnel" log files are written.
> >
> > The icon log displayed the following message in version 4.18 and 4.20
> > 2007.11.09 09:41:03 LOG3[2396:2400]: stunnel.log: Broken pipe (32)
> > 2007.11.09 09:41:03 LOG3[2396:2400]: Unable to open output file:
> > stunnel.log
> 
> Did you try to specify full file path (e.g. c:\stunnel.log)?
> 
> Best regards,
> 	Mike
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at mirt.net
> http://stunnel.mirt.net/mailman/listinfo/stunnel-users
> 


-- 
Gonzalo Diethelm
gonzalo.diethelm at diethelm.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20071112/aabf5ec5/attachment.html>


More information about the stunnel-users mailing list