[stunnel-users] Trying to get stunnel to work for forwarding pop3s to ipop3 port

Van vanyel at medusa.bioc.aecom.yu.edu
Thu Jun 21 01:03:00 CEST 2007


This is my introduction to stunnel. I've inherited control of a pop3  
and imap server running Red Hat Linux 4 that I want to access via  
pop3s and imaps. I'm starting out with securing the pop3 since most  
users are using it.

I downloaded stunnel 4.20 and compiled it according to the  
instructions on stunnel.org.

I read the certificates section of the site and made a new .pem file  
that I named mail.pem and have in the /usr/local/etc/stunnel/  
directory that /usr/local/etc/stunnel/stunnel.conf asks for.  But  
when I try to run stunnel like in the Examples section I get :

[van at mailserver ~]$ sudo /usr/local/sbin/stunnel -d pop3s -r  
2007.06.20 17:59:54 LOG3[25516:3086419648]: -d: No such file or  
directory (2)
stunnel [<filename>] ] -fd <n> | -help | -version | -sockets
     <filename>  - use specified config file instead of /usr/local/ 
     -fd <n>     - read the config file from a file descriptor
     -help       - get config file help
     -version    - display version and defaults
     -sockets    - display default socket options

I'm a little lost here. Never dealt with a .pem file before stunnel.  
I have a self-signed cert I'm successfully using for https webmail on  
the server and guessing stunnel couldn't see that, I appended my file  
'mailserver.crt' into  my mail.pem file and edited stunnel.conf so it  

;CAfile = /usr/local/etc/stunnel/certs.pem
CAfile = /usr/local/etc/stunnel/mail.pem

but no dice. Same result.

Trying to debug, I find 'stunnel -V' also gives the same result.

Can someone point out what's going wrong?


More information about the stunnel-users mailing list