[stunnel-users] SSL Libraries on Debian

Hal Vaughan hal at thresholddigital.com
Tue Mar 14 14:31:02 CET 2006

On Tuesday 14 March 2006 03:57, Michal Trojnara wrote:
> Hal Vaughan wrote:
> > I tried compiling Stunnel on Debian and get an error -- I
> > need the ssl
> > libraries.  I tried ./configure --with-ssl=/usr/lib/ssl,
> > which is where
> > libssl-dev was installed, and it doesn't help.
> You're wrong.  libssl-dev installs libraries in /usr/lib:

Hmmmm....  I had not /usr/lib/ssl until I installed libssl-dev, so it 
must put some files in there.

> $ dpkg -L libssl-dev | grep libcrypto
> /usr/lib/libcrypto.a
> /usr/lib/libcrypto_pic.a
> /usr/lib/libcrypto.so

Saw these now, don't know if they were there earlier.

> For stunnel you should use:
> ./configure --with-ssl=/usr

Yes!  It works just fine.  I had tried /usr/lib/ssl and /usr/lib without 
luck, but finally it works with this.

> since that's the prefix OpenSSL libraries and includes are installed
> on Debian.
> BTW: Simple ./configure works fine on Debian.

For some reason it isn't working on my system (running Sid).  Tried it 
several times and got the same error (no ssl libs).

Thanks -- I can get ./configure working now.  Some problems with make, 
but I don't have time to look deeper into that now.  It'll have to wait 
until later today.


More information about the stunnel-users mailing list