[stunnel-users] 4.10 Crashes with Multiple Connections

Eddie Atherton stunnel at attglobal.net
Thu Jun 30 21:11:48 CEST 2005

Hi.  Just started to use stunnel for NNTP traffic to Giga on a gateway 
Linux 2.4 box that sits between Windows and my cable modem.  The 
NewsReader I use is configured to open 4 connections at the same time.

Downloaded and installed 4.10, then immediately hit the -lpthread 
problem.  Edited the Makefile, did a "make clean", "make", and "make 
install".  Tried again.  Got an immediate crash.  Tried a few more 
times.  Sometimes it crashed, other times the NewsReader reported one 
connection as working, one as connected, but not pulling any data, and 
two connections as connecting.  So, it looks like everything works with 
only one active connection, but it segfaults when 2 or more threads are 
pulling data.  The problem is, I can't always get it to crash.  Plus, 
cpu use of stunnel sometimes pegs at 99%, even after closing the 
connections, and again this isn't consistent.

When I turn debug on, it has always only used one active connection, so 
I don't get the crash.  Plus, when debug is on, and I terminate the 
connections from the NewsReader, the log file expanded to 18meg in less 
than a minute.

I then downloaded and installed 4.9, and this appears to handle the 4 
active connections without any problems.

Any suggestions as to what kind of information I should try and collect 
for this.


More information about the stunnel-users mailing list