[stunnel-users] stunnel library inconsistencies

Michal Trojnara Michal.Trojnara at mobi-com.net
Thu Dec 29 09:49:14 CET 2005


Brian,
 
Here is what I've found googling on your problem:
 <http://www.mail-archive.com/openssl-dev@openssl.org/msg11649.html>
http://www.mail-archive.com/openssl-dev@openssl.org/msg11649.html
I guess the problem is in your gcc or glibc.
 
BTW: stunnel 4.08 does not use realloc (but openssl does).  8-)
 
Best regards,
    Mike

  _____  

From: stunnel-users-bounces at mirt.net [mailto:stunnel-users-bounces at mirt.net]
On Behalf Of Brian T
Sent: Thursday, December 29, 2005 1:40 AM
To: stunnel-users at mirt.net
Subject: [stunnel-users] stunnel library inconsistencies


Hi,
 
I've been using stunnel 4.08 on an embedded Linux platform for a while now,
and am attempting to move to the 2.6 kernel from the 2.4.20, which has
changed my building platform.  I am cross-compiling with libs and tools
targeted for the embedded system, which is an i486 type AMD Elan chip.
 
I have tried 4.08, 4.14 and 4.15b, all with the same result. Everything
looks to compile properly, but when running stunnel I get the following:
 
Inconsistency detected by ld.so: dl-minimal.c: 134: realloc: Assertion `ptr
== alloc_last_block' failed!
 
strace doesn't supply any helpful information.   I have tried building with
and without tcpwrappers, and have tried libssl 0.9.7g and 0.9.7i.  Libssl
v0.9.8a doesn't seem to play very nice.
 
Anyone able to look at my config.log?  It's 140k uncompressed, but will zip
it up if needed.
 
Thanks,
 
-Brian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20051229/04beb14a/attachment.html>


More information about the stunnel-users mailing list