[stunnel-users] Stunnel to smtp-relay.gmail.com

Anton Palmgård anton at dbsmaland.se
Mon Sep 21 18:08:06 CEST 2020

Hi, a few days ago up to a week my stunnel connection to smtp-gmail.gmail.com. stopped working with the error:

ep 21 17:25:57 stunnel LOG50: Connection reset: 0 byte(s) sent to TLS, 0 byte(s) sent to socket
Sep 21 17:25:57 stunnel LOG30: Remote server is not RFC 1425 compliant
Sep 21 17:25:57 stunnel LOG50: Service [to_gmail] connected remote server from xxx.xxx.xxx.xxx:29662

Tried from 2 different Locations / sites (i.e companies) same error. The relay work fine without client settings but that leaves TLS to the endpoint.. Office 365 relay works fine with TLS. Contacted Google support but the claimed nothing have been changed. I assume somehting with the TLS version/ CIPHERS is wrong ?

Conf simply looks like this:

cert = /usr/local/etc/stunnel/stunnel.pem
chroot = /var/tmp/stunnel
setuid = stunnel
setgid = stunnel

client = yes
accept =
connect = smtp-relay.gmail.com:587
debug = 7
TIMEOUTclose = 0
protocol = smtp

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20200921/85d9a927/attachment.htm>

More information about the stunnel-users mailing list