[stunnel-users] Stunnel 5.56 Windows 10 Service - Not functioning after Reboot

Rod Marr rodmarr at live.com
Sun Aug 16 20:01:43 CEST 2020

Jose, thanks so much. That solved the problem.

In Windows 10 SERVICES.MSC for Stunnel I set the Start Up Type to “Automatic (Delayed Start)”. At boot time this queues the services set that way to start after the core services are running – including the TCP/IP stack.

All good now and my Stunnel/Blue Iris experience has improved greatly.

Thanks again,

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

From: Josealf.rm<mailto:josealf at rocketmail.com>
Sent: Friday, August 14, 2020 9:06 PM
To: Rod Marr<mailto:rodmarr at live.com>
Cc: stunnel-users at stunnel.org<mailto:stunnel-users at stunnel.org>
Subject: Re: [stunnel-users] Stunnel 5.56 Windows 10 Service - Not functioning after Reboot

Ho Rod,

Maybe the stunnel service is starting too early. You may want create a service dependency on another service like the DNS client, to delay the start and be sure any Tcp/ip stack dependencies are ready.


On Aug 14, 2020, at 4:20 PM, Rod Marr <rodmarr at live.com<mailto:rodmarr at live.com>> wrote:
Hi all,

I have installed Stunnel 5.56 win64 on a fully updated Windows 10 machine to work with Blue Iris. Stunnel operates well when I manually start it however I cannot get it to work automatically after a reboot.

I have run the run the “stunnel Service Install” and “stunnel Service Start” shortcuts supplied, and in the first instance the service installs and starts. I can then connect through Stunnel to my Blue Iris server.

I have found that after I reboot, the Stunnel service appears to start automatically but it is not functional. I cannot connect through it to Blue Iris. Stunnel is visible and Running in the Windows 10 Services list (from services.msc) and the Windows Task Manager shows a Process and Service active.

To rectify this I can manually issue the “stunnel Service Stop”, followed by the “stunnel Service Start” shortcuts and the service becomes functional again.

I have tried turning on debug info and the stunnel log file in stunnel.conf and see that log entries only begin after I have done the stop/start manual process.

Thanks for any insight to what I’m sure I am missing here.


Sent from Mail<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3FLinkId%3D550986&data=02%7C01%7C%7C6bdee7654fa84a935fc608d840b77aec%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637330504065425465&sdata=SECCop10YwePA%2F5YtrjLItQo89%2B1M%2FpmQzfW%2FG3EpBw%3D&reserved=0> for Windows 10

stunnel-users mailing list
stunnel-users at stunnel.org<mailto:stunnel-users at stunnel.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20200816/7b91a178/attachment.htm>

More information about the stunnel-users mailing list