[stunnel-users] Stunnel 5.55 on Win 10 x64 GUI Mode

Thomas Eifert kxkvi at wi.rr.com
Sun Jun 16 03:43:14 CEST 2019

Tonight, I downloaded and installed Stunnel version 5.55 and installed 
it on Windows 10 x64 1903.

If I run Stunnel as a service, everything works beautifully.  No issues 
whatsoever.   However, I just
can't seem to get it to run in GUI mode.  When I fire up the GUI, the 
configuration file loads fine
with no errors.  However, when attempting to establish any connection, 
the GUI simply crashes
and the log file just terminates with nothing revealing:

2019.06.15 20:26:02 LOG7[main]: Service [ircs.3] accepted (FD=956) from
2019.06.15 20:26:02 LOG7[main]: Creating a new thread
2019.06.15 20:26:02 LOG7[main]: New thread created
2019.06.15 20:26:02 LOG7[0]: Service [ircs.3] started
2019.06.15 20:26:02 LOG7[0]: Setting local socket options (FD=956)
2019.06.15 20:26:02 LOG7[0]: Option TCP_NODELAY set on local socket
2019.06.15 20:26:02 LOG5[0]: Service [ircs.3] accepted connection from
2019.06.15 20:26:02 LOG6[0]: s_connect: connecting
2019.06.15 20:26:02 LOG7[0]: s_connect: s_poll_wait 
waiting 10 seconds
2019.06.15 20:26:02 LOG7[0]: FD=1080 ifds=rwx ofds=---

(end of log)

This is, of course, with the service stopped and de-installed.

I've tried several remedies, including running Stunnel in compatibility 
modes, running it as an
administrator, and I even tried to install it completely outside of the 
normal "program files (x86)" location.
Also, the firewall is not the issue.

Nothing seems to help.  I can't figure out what on earth is occurring.

Any insight/ideas would be appreciated.

Thanks and regards,


Attention: This message and all attachments are private and may contain information that is confidential and privileged. If you received this message in error, please notify the sender by reply email and delete the message immediately.

More information about the stunnel-users mailing list