[stunnel-users] Tunnel from win32 to Unix

Eetu Pikkarainen eetu.pikkarainen at oulu.fi
Tue Feb 26 09:14:05 CET 2019

I am a totally newbie with this. We have intranet system in Windows Server (32bit) which reads a database (Oracle) situated in Unix machine via a tunnel made by Putty.exe. That works well except that the connection gets lost every now and then and it must be manually logged in every time. So I decided to try stunnel which we used earlier to read email from email server. 
However I cannot set the connection successfully. This is what I have tried now (among many other alternatives):

client = yes
accept =
connect = kanto2.oulu.fi:22
protocolUsername = <username>
protocolPassword = <password>

stunnel reads the configuration OK except this notification:

  [:] Service [Kanto2] needs authentication to prevent MITM attacks

but when the database is tried to read happens this:

  2019.02.18 13:32:30 LOG5[1]: Service [Kanto2] accepted connection from
  2019.02.18 13:32:30 LOG5[1]: s_connect: connected
  2019.02.18 13:32:30 LOG5[1]: Service [Kanto2] connected remote server from
  2019.02.18 13:32:30 LOG3[1]: SSL_connect: 140770FC: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
  2019.02.18 13:32:30 LOG5[1]: Connection reset: 0 byte(s) sent to TLS, 0 byte(s) sent to socket

I have tried different protocol alternatives with no help.
What could be the problem? Is this kind of use even possible?


Eetu Pikkarainen
PhD (Ed.), (Title of) Adjunct Prof., University Lecturer (in Education) Faculty of Education, University of Oulu, Finland Research Group: https://wiki.oulu.fi/display/theored

Latest publications:

    Semiotic Theory of Learning: New Perspectives in the Philosophy of Education.
    By Andrew Stables, Winfried Nöth, Alin Olteanu, Sébastien Pesce and Eetu Pikkarainen

    Schools in Transition: Linking Past, Present, and Future in Educational Practice.
    Edited by Pauli Siljander, Kimmo Kontio and Eetu Pikkarainen

More information about the stunnel-users mailing list