[stunnel-users] stunnel log rolling

Daniel Trickett daniel.trickett at emdmillipore.com
Wed Sep 12 14:43:20 CEST 2018


Kill the stunnel process. Then mv the log. This will allow stunnel to right to a new log file.

Best regards,


Daniel Trickett
Head of Database Services | MBS Business Technology
Business Services of Merck KGaA, Darmstadt, Germany

Planned Absence –

A business of Merck KGaA, Darmstadt, Germany

EMD Millipore Corporation | 80 Ashby Road | Bedford, MA 01730 | USA
office 781-533-3017 |cell 978-761-3506 |email daniel.trickett at emdmillipore.com<mailto:daniel.trickett at emdmillipore.com>

From: stunnel-users <stunnel-users-bounces at stunnel.org> On Behalf Of Tom Hood
Sent: Tuesday, September 11, 2018 5:02 PM
To: stunnel-users at stunnel.org
Subject: [stunnel-users] stunnel log rolling


I'm new to stunnel and it isn't clear to me how the log rolling feature works.

I built stunnel 5.49 with gcc 4.2.0 on Solaris 10.  I'm running it on Solaris 11.3 SPARC.  Using openssl 1.0.2p

The config file has disabled syslog and is logging to stunnel.log.

Command line is:  stunnel stunnel.conf
where stunnel.conf contains the following:
syslog = no
output = stunnel.log
debug = 7

client = no
options = NO_SSLv2
options = NO_SSLv3
options = NO_TLSv1
options = NO_TLSv1.1
options = -NO_TLSv1.2
cert = /path/to/stunnel.pem
curve = zzz
accept = testhost:32100
connect =<>

client = yes
options = NO_SSLv2
options = NO_SSLv3
accept =<>
connect =<>
sslVersion = TLSv1
ciphers = zzz
TIMEOUTconnect = 60

The log rollowing steps I tried that don't work are:
mv stunnel.log stunnel.log.1
kill -USR1 <stunnelpid>

The log message "LOG7[main]: Processing SIGNAL_REOPEN_LOG" shows up in stunnel.log.1. However, new client connections to host:32100 do not trigger creation of a new stunnel.log file.  In fact, logging stops to stunnel.log.1 as soon as the USR1 is processed.  The new client connections work as before, but there isn't any logging.

I restarted stunnel and tried the test again with these steps:
mv stunnel.log stunnel.log.1
touch stunnel.log
kill -USR1 <stunnelpid>
That also doesn't work.

Please let me know the correct sequence of steps to roll the stunnel.log

Thank you,
-- Tom

This message and any attachment are confidential and may be privileged or otherwise protected from disclosure. If you are not the intended recipient, you must not copy this message or attachment or disclose the contents to any other person. If you have received this transmission in error, please notify the sender immediately and delete the message and any attachment from your system. Merck KGaA, Darmstadt, Germany and any of its subsidiaries do not accept liability for any omissions or errors in this message which may arise as a result of E-Mail-transmission or for damages resulting from any unauthorized changes of the content of this message and any attachment thereto. Merck KGaA, Darmstadt, Germany and any of its subsidiaries do not guarantee that this message is free of viruses and does not accept liability for any damages caused by any virus transmitted therewith.

Click http://www.emdgroup.com/emd/imprint/mail_disclaimer.html to access the German, French, Spanish and Portuguese versions of this disclaimer.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20180912/77cf05ab/attachment.html>

More information about the stunnel-users mailing list