[stunnel-users] stunnel log rolling

Tom Hood tom.w.hood at gmail.com
Tue Sep 11 23:01:47 CEST 2018


I'm new to stunnel and it isn't clear to me how the log rolling feature

I built stunnel 5.49 with gcc 4.2.0 on Solaris 10.  I'm running it on
Solaris 11.3 SPARC.  Using openssl 1.0.2p

The config file has disabled syslog and is logging to stunnel.log.

Command line is:  stunnel stunnel.conf
where stunnel.conf contains the following:
syslog = no
output = stunnel.log
debug = 7

client = no
options = NO_SSLv2
options = NO_SSLv3
options = NO_TLSv1
options = NO_TLSv1.1
options = -NO_TLSv1.2
cert = /path/to/stunnel.pem
curve = zzz
accept = testhost:32100
connect =

client = yes
options = NO_SSLv2
options = NO_SSLv3
accept =
connect =
sslVersion = TLSv1
ciphers = zzz
TIMEOUTconnect = 60

The log rollowing steps I tried that don't work are:
mv stunnel.log stunnel.log.1
kill -USR1 <stunnelpid>

The log message "LOG7[main]: Processing SIGNAL_REOPEN_LOG" shows up in
stunnel.log.1. However, new client connections to host:32100 do not trigger
creation of a new stunnel.log file.  In fact, logging stops to
stunnel.log.1 as soon as the USR1 is processed.  The new client connections
work as before, but there isn't any logging.

I restarted stunnel and tried the test again with these steps:
mv stunnel.log stunnel.log.1
touch stunnel.log
kill -USR1 <stunnelpid>
That also doesn't work.

Please let me know the correct sequence of steps to roll the stunnel.log

Thank you,
-- Tom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20180911/b4fae2aa/attachment.html>

More information about the stunnel-users mailing list