[stunnel-users] Versions

Peter Pentchev roam at ringlet.net
Thu Jan 4 09:08:02 CET 2018

On Wed, Jan 03, 2018 at 04:01:50PM -0800, Editor wrote:
> Hi:
> On the various repo sites for Redhat-CentOS-Oracle Linux, etc., they are
> only providing version 4.29 of stunnel. Is there anyway to push them an
> updated version?
> I normally use these repo providers:
> Oracle Linux repo
> EPEL 6 Repo
> rpmforce Repo

Unfortunately it does seem that stunnel-5.x is not available through
any of the official and even semi-official package repositories for
CentOS 6.

> In the end, I tried to compile the latest version on Linux but I get this
> somewhat cryptic message about a TLS installation directory. I never had
> this issue before but to be honest, I normally used Solaris (8-9-10) in the
> past.
> "Could not find your TLS library installation dir
> Use --with-ssl option to fix this problem"
> I tried pointing it at /usr/bin/openssl and also at /usr/lib64/openssl
> without any luck.

To compile programs that use a library, you need not only the library
files themselves, but also the so-called header files that describe for
the compiler what functions and data types are defined and used in
the library.  Most Linux distributions keep these files in a separate
package, e.g. on CentOS 6 for OpenSSL there is the "openssl" package
that contains the libraries themselves and then there is "openssl-devel"
with the header files.  Try installing the openssl-devel package and
rerunning the stunnel configure script; it should be able to pick up
the OpenSSL header files without any special --with-ssl options,
it knows where to look for the most common installation directories.

Hope that helps!

Best regards,

Peter Pentchev  roam at ringlet.net roam at FreeBSD.org pp at storpool.com
PGP key:        http://people.FreeBSD.org/~roam/roam.key.asc
Key fingerprint 2EE7 A7A5 17FC 124C F115  C354 651E EFB0 2527 DF13
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20180104/8d966c49/attachment.sig>

More information about the stunnel-users mailing list