[stunnel-users] Exception 40000015 STATUS_FATAL_APP_EXIT

alexwaskilledfriendlyfire at gmail.com alexwaskilledfriendlyfire at gmail.com
Tue Dec 5 08:03:34 CET 2017


Hello Alexwaskilledfriendlyfire,

Wednesday, November 29, 2017, 1:28:14 AM, you wrote:

> Hello Stunnel-users,

> Well,  I have a problem with latest stunnel-5.44-win32 build. Both GUI
> and console versions won't to start throwing unhandled exception:

> tstunnel.exe:

> Problem signature:
>   Problem Event Name:   APPCRASH
>   Application Name:     tstunnel.exe
>   Application Version:  0.0.0.0
>   Application Timestamp:        5a18f4f5
>   Fault Module Name:    tstunnel.exe
>   Fault Module Version: 0.0.0.0
>   Fault Module Timestamp:       5a18f4f5
>   Exception Code:       40000015
>   Exception Offset:     0000e43d
>   OS Version:   6.1.7601.2.1.0.256.4
>   Locale ID:    1049
>   Additional Information 1:     57b4
>   Additional Information 2:     57b4bc5bbe66a065d3bc087357c09646
>   Additional Information 3:     f6bb
>   Additional Information 4:     f6bb7b9b6fcf2c5cdb238bc389e9ede9








> And GUI version
> stunnel.exe:

> ---------------------------
> Microsoft Visual C++ Runtime Library
> ---------------------------
> Runtime Error!

> Program: C:\Progs\Stunnel\bin\stunnel.exe



> This application has requested the Runtime to terminate it in an unusual way.
> Please contact the application's support team for more information.


> ---------------------------
> OK   
> ---------------------------

> Problem signature:
>   Problem Event Name:   APPCRASH
>   Application Name:     stunnel.exe
>   Application Version:  5.44.0.0
>   Application Timestamp:        5a18f4f3
>   Fault Module Name:    stunnel.exe
>   Fault Module Version: 5.44.0.0
>   Fault Module Timestamp:       5a18f4f3
>   Exception Code:       40000015
>   Exception Offset:     0000e43d
>   OS Version:   6.1.7601.2.1.0.256.4
>   Locale ID:    1049
>   Additional Information 1:     2de9
>   Additional Information 2:     2de98e0ccee9cc0b77f8fe3f51196ec8
>   Additional Information 3:     42db
>   Additional Information 4:     42db6f5f1de1e71ee661917dbb7cc0c8

> Completely  fresh  isntallation  (or  deleting  config folder) doesn't
> solve my problem. My OS is legal Windows 7 x64 with latest updates.

> There are screenshots just for case.
> https://i.imgur.com/N1kPI9J.jpg
> https://i.imgur.com/CqMXWtx.jpg

> Probably I missing some DLL or service running but it's not an option
> to  turn  everything ON (and copy every single DLL ever made to my PC)
> to determine which one is not running. Probably it's something else.

> I need help. Thanks.


Thanks for the reply. This is stunnel.conf: https://pastebin.com/W684eunH
I  don't  think  it'll  help  a  lot because Stunnel crashes even with
default config file (and default key) right after fresh installation.

I'm  using  COMODO  Internet  Security.  But  turning all protective
features OFF (Firewall disabled, HIPS disabled, Auto-sandbox disabled,
viruscope disabled) doesn't help at all.

There's  definitely  something wrong in system configuration and/or in
Stunell but I even don't know in which direction should I advance.

-- 
Best regards,
 Alexwaskilledfriendlyfire                            mailto:alexwaskilledfriendlyfire at gmail.com



More information about the stunnel-users mailing list