[stunnel-users] Configuring Stunnel to work between client and server - possible certificate issue

David Faizulaev David.Faizulaev at nextnine.com
Mon May 16 18:25:04 CEST 2016


I've found Stunnel as a potential answer to securely moving traffic between two machines.
But I'm having some difficulties configuring the software.

I've installed it on to the client machine and configured the client to connect to while the Server to which the client needs to connect is
In the stunnel.conf I've set the following:

accept =
connect =
cert = 220.72.cer
TIMEOUTclose = 0

Upon initializing Stunnel I get the following error:

2016.05.16 19:14:04 LOG3[main]: error queue: 140B0009: error:140B0009:SSL routines:SSL_CTX_use_PrivateKey_file:PEM lib
2016.05.16 19:14:04 LOG3[main]: SSL_CTX_use_PrivateKey_file: 906D06C: error:0906D06C:PEM routines:PEM_read_bio:no start line
2016.05.16 19:14:04 LOG3[main]: Service [custom]: Failed to initialize SSL context
2016.05.16 19:14:04 LOG3[main]: Failed to reload the configuration file

What can be the cause?
Thanks in advance.

Best Regards,


David Faizulaev | PL/SQL Developer | T  +972 (3) 767 3026<tel:%2B97237673012> | M +972 (54) 7314<tel:%2B972528466746>687

Centralized OT Security Management for Distributed SCADA/ICS Networks

P Please consider the environment before printing this e-mail

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20160516/89dfb52b/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 11900 bytes
Desc: image001.png
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20160516/89dfb52b/attachment-0001.png>

More information about the stunnel-users mailing list