[stunnel-users] Windows 2012 R2 Error on startup

Rob Lockhart rlockhar at gmail.com
Sun Sep 13 04:03:53 CEST 2015

According to your log files, something else is already listening on port 25.

from stunnel.conf:

; GMail ssmtp settings
accept = 25
connect = smtp.gmail.com:465

and from error log:

[!] Error binding service [ssmtp] to
[!] bind: No error (0)

That means if you're running Window Server, you should use a different port
than 25, as something else on your system is already using that (for SMTP,
presumably). Have you simply tried a different port, possibly higher than
1024 (like, 1465), then configure the client to connect to localhost to
that port (1465). Then it should connect to your gmail SMTP server. If you
can turn off SMTP on your Windows 2012 server, I would try that first.

I don't think this is a stunnel issue but an issue in trying to create an
additional service listening on a port for which there is already a
listening service.


On Sat, Sep 12, 2015 at 4:52 PM, Han-Earl Guhm <hanguhm at educatingforlife.com
> wrote:

> I installed the latest version of stunnel and am having problems starting
> it up. I have attached an error log and my config file. I tested on Windows
> 7 and it worked with no problems, but I would really like it to work on my
> Windows 2012 server.
> Thank you,
> Han-Earl Guhm
> Coventry Christian Schools
> hanguhm at educatingforlife.com
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at stunnel.org
> https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20150912/c212de13/attachment.html>

More information about the stunnel-users mailing list