[stunnel-users] No DNS lookup?

Ludolf Holzheid lholzheid at bihl-wiedemann.de
Tue Jan 20 16:07:57 CET 2015

On Tue, 2015-01-20 09:33:04 +0000, Colin vd Zanden wrote:
> Hi,
> We've got a bit of a problem working with Stunnel. We are trying to
> connect to a domain, but the stunnel is somehow translating it to a
> IP adres. (We didn't know, we saw it in the log file). This is
> causing our connection to fail. Is there any way to prevent stunnel
> from translating the domain into a IP, and just connect to the
> domain name?


All connections in the Internet go to IP addresses.  In the first
instance, the domain name system is merely a way to avoid the need to
remember all those numbers.  If you type an URL into the location bar
of your web browser, the first thing your computer does is to resolve
the DNS name into an IP address.

Moreover, you don't connect to domains, but to hosts.  The domain is
the part of the host name right to the leftmost dot and is an abstract
entity, same as the area code is not a telephone number.

/Maybe/ you are trying to connect to a host with a dynamic IP address
and suffer from the fact, stunnel usually resolves the DNS names at
start up.  If this is the case, you might take a look at the 'delay'
service-level option of stunnel.




Bihl+Wiedemann GmbH
Floßwörthstraße 41
68199 Mannheim, Germany
Tel: +49 621 33996-0
Fax: +49 621 3392239
mailto:lholzheid at bihl-wiedemann.de
Sitz der Gesellschaft: Mannheim
Geschäftsführer: Jochen Bihl, Bernhard Wiedemann
Amtsgericht Mannheim, HRB 5796

More information about the stunnel-users mailing list