[stunnel-users] Errors after upgrading to 5.07

Mikhail Idris mikhail.idris at gmail.com
Mon Nov 17 11:33:46 CET 2014

Hello Michal,

The operating system that I am currently using is Windows 2008 R2 (with the
latest windows update applied).

As for upgrading OpenSSL, I don't recall having do that, as I am using the
binaries that was included in the installer by default.
No previous custom/manual installation of OpenSSL either.

As much as I would like to try the 5.08b immediately, but I am unable to do
so as prices/trades are currently active/live.

I have included a truncated stunnel.log as attachment.

For your convenience, I have uploaded it to


Thank you.


On Mon, Nov 17, 2014 at 5:24 PM, Michal Trojnara <Michal.Trojnara at mirt.net>

> Hash: SHA1
> Mikhail Idris wrote:
> > I have recently upgraded to 5.07.
> >
> > But now, the console is spamming with messages such as:
> >
> > SSL_read returned WANT_READ: retrying
> >
> > Is this a critical error?
> >
> > Will it have any impact of any services that are currently using
> > stunnel?
> It is a debug message.
> It is probably harmless, but I'd like to be sure about it.
> Did you also upgrade your OpenSSL?  What is your current version?
> Can you reproduce the problem with the latest 5.08 beta version?
> https://www.stunnel.org/downloads.html
> TIA,
>         Mike
> Version: GnuPG v1
> BMwAoNvrsdvTmLSg0/IY5oBD6+HBbiZm
> =V7WQ
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at stunnel.org
> https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20141117/8ae95fe1/attachment.html>

More information about the stunnel-users mailing list