[stunnel-users] Output to neither stdout nor stderr it seems

Casper Thomsen ct at clearhaus.com
Mon Nov 10 15:51:05 CET 2014

Hi stunnel-users

I run stunnel4 in docker with the following config file:
--- /etc/stunnel/stunnel.conf --------------
sslVersion = SSLv3

pid = /var/lib/stunnel4/stunnel4.pid

socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1

verify = 2
CApath = /etc/ssl/certs

debug = notice
output = /var/log/stunnel.log

client = yes
foreground = yes

accept  = 1234
connect =
TIMEOUTclose = 3

When I run stunnel and pipe stdout and stderr to /dev/null, I still get output:

root at 849b7eb3bbd0:/# /usr/bin/stunnel4 /etc/stunnel/stunnel.conf
2>/dev/null >/dev/null
stunnel: LOG5[258:140421949949696]: stunnel 4.53 on x86_64-pc-linux-gnu platform
stunnel: LOG5[258:140421949949696]: Compiled/running with OpenSSL
1.0.1e 11 Feb 2013
stunnel: LOG5[258:140421949949696]: Threading:PTHREAD SSL:+ENGINE+OCSP
Auth:LIBWRAP Sockets:POLL+IPv6
stunnel: LOG5[258:140421949949696]: Reading configuration from file
stunnel: LOG5[258:140421949949696]: Configuration successful
^Cstunnel: LOG3[258:140421949949696]: Received signal 2; terminating

Complete shell output is attached.

Any hints on what's happening?

Casper Thomsen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: shell-output
Type: application/octet-stream
Size: 5733 bytes
Desc: not available
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20141110/cbb0f138/attachment.obj>

More information about the stunnel-users mailing list