[stunnel-users] Truncated responses with stunnel >= 5.05

Graham Nayler (work) graham.nayler at hallmarq.net
Fri Nov 7 13:58:06 CET 2014


Hmmm... at first sight this sounds like exactly the scenario I was concerned 
about back when the change was made (but got no response).

https://www.stunnel.org/pipermail/stunnel-users/2014-September/004765.html

Graham

----- Original Message ----- 
From: "Tuomas Silen" <tuomas at silen.fi>
To: <stunnel-users at stunnel.org>
Sent: Friday, November 07, 2014 11:43 AM
Subject: Re: [stunnel-users] Truncated responses with stunnel >= 5.05


>
> On 07/11/14 08:48, Michal Trojnara wrote:
>> Tuomas Silen wrote:
>>> LOG3[31153]: transfer: s_poll_wait: TIMEOUTclose exceeded: closing
>>
>> Could you please share your stunnel.conf and some debug logs?
>> I need all the logs generated by stunnel for the problematic connection.
>>
>
> Sure, the config and debug level log of both working and
> non-working connection are available at
> https://gist.github.com/anonymous/44c47b3893c3ebf45018
>
> Also worth noting is that if the client uses Connection: keep-alive
> (instead of Connection: close), the problem does not appear, possibly
> because the connection isn't closed right away.
>
> It also only seems to appear if the response body is large enough.
>
> I'll see if I can come up with some minimal setup to reliably
> reproduce it.
>
> Best regards,
>
> -Tuomas
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at stunnel.org
> https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users
> 



More information about the stunnel-users mailing list