[stunnel-users] Stunnel - how to make Google App Engine HTTP into HTTPS ?

Shamun Toha Md shamun at companysocia.com
Thu Feb 6 08:22:18 CET 2014

I have Google App Engine running in HTTP (port tcp 80), which is a daemon
based service it execute back-end some python instances. Now all that works
over HTTP , TCP 80, and Google App Engine itself do not have any kind of
HTTPS setup, it has to be organized externally.

Therefore, the biggest problem is now that how can i use stunnel to resolve
this problem please?
I have already tried following setup and it does not work at all.

1) if the user visit https://www.mysite.com then he hit stunnel accept=443
after that he is connected with connect=80 but user browser change into
http:// instead of remaining in https:// . Which make the whole thing not

$ uname -a
Linux server2 2.6.32-358.23.2.el6.x86_64 #1 SMP Wed Oct 16 18:37:12 UTC
2013 x86_64 x86_64 x86_64 GNU/Linux
$ cat /etc/stunnel/stunnel.conf
pid = /stunnel.pid


sslVersion = all
;socket = l:TCP_NODELAY=1
;socket = r:TCP_NODELAY=1

debug = 7
output = /var/log/stunnel.log

TIMEOUTclose = 0

My goal is: when user visit https://www.mysite.com it remain as https not
become http:// then it is not solving the problem cause Google app engine
do not have HTTPS

Thank you.

Best regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20140206/65305924/attachment.html>

More information about the stunnel-users mailing list