[stunnel-users] stunnel domain name resolution bug

Brian Wilkins bwilkins at gmail.com
Sat Dec 7 00:18:50 CET 2013

Sent you traffic from Sept 19th from Trojnara. May be helpful
On Dec 6, 2013 6:11 PM, "Brian Wilkins" <bwilkins at gmail.com> wrote:

> See my forward
> On Dec 6, 2013 5:53 PM, "David Slachta" <elpin at volny.cz> wrote:
>>  I'm new to the mailing lists so I hope it's the correct way to report a
>> bug.
>> There's an issue with resolving domain names. I'm connecting an stunnel
>> client to a server that sits on a computer which IP address is dynamic.
>> Therefore I'm using a dyndns for the IP address of the server. When the IP
>> address of the server is changed, the stunnel client doesn't update the
>> name resolution of the dyndns name and tries to connect to the old IP which
>> is of course unsuccessful. This can be resolved only by exiting and
>> starting stunnel client again when a new domain name resolution is made.
>> Would it be possible to add a functionality to the stunnel that wouldn't
>> cache the name resolution but try to resolve the domain names every time
>> there's a connection request?
>> I'm using a Windows OS for both server and client, not sure if that makes
>> a difference.
>> Thanks!
>> David
>> _______________________________________________
>> stunnel-users mailing list
>> stunnel-users at stunnel.org
>> https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20131206/c795d55e/attachment.html>

More information about the stunnel-users mailing list