[stunnel-users] Stunnel blocks booting process when no network connectivity

Muschi Stevenson muschistevenson at googlemail.com
Tue Sep 25 11:17:41 CEST 2012

That seems to have solved it however I also had to change delay to
delay=yes as it still doesn't work with delay=no.

delay=yes is ok for me as from what I could gather this makes a DNS
resolution everytime it attempts to start a tunnel. Is that correct?

During testing if the IP was changed for "stunnel.mydomain.com" with
delay=no stunnel would never adapt to the new IP, I remember reading
that delay=yes would solve this particular case also. Again, is that

Would be helpful if someone could explain this option more in detail
as i couldn't take much from the man page

On Mon, Sep 24, 2012 at 6:05 PM, Michal Trojnara
<Michal.Trojnara at mirt.net> wrote:
> On 2012-09-24 17:53, Muschi Stevenson wrote:
>> [someservice]
>> accept=12121
>> connect=stunnel.mydomain.com:12121
>> delay=NO
> This is what I expected.  Move "delay" before "connect".
> Preferably to global options (i.e. before any service sections).
> Let me know if this workaround works, so I can fix the root cause.
> Mike
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at stunnel.org
> https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users

More information about the stunnel-users mailing list