[stunnel-users] FIPS_mode_set:fingerprint does not match

Jake Skinner Jake.Skinner at ontariosystems.com
Thu Mar 1 03:25:52 CET 2012

Have you tried disabling FIPS to see if your connection works without?

Jake Skinner
Telephony Technology Specialist
Ontario Systems, LLC
Office +1.765.751.7000

Thumbed posthaste from my mobile device; please forgive any typing or grammatical errors.

From: stunnel-users-bounces at stunnel.org
To: stunnel-users at stunnel.org
Sent: Wed Feb 29 19:41:02 2012
Subject: [stunnel-users] FIPS_mode_set:fingerprint does not match

I have the following problem running stunnel on Centos 6.x 64bit with the following error:

I have been search with google to see if there was a solution but nothing was found

Thank you for your reply and your help, hopefully I can get this solved.


Clients allowed=500
stunnel 4.52 on x86_64-unknown-linux-gnu platform
Compiled/running with OpenSSL 1.0.0-fips 29 Mar 2010
Threading:PTHREAD SSL:ENGINE,FIPS Auth:none Sockets:POLL,IPv6
Reading configuration from file /usr/local/etc/stunnel/stunnel.conf
FIPS_mode_set: 2D06C06E: error:2D06C06E:FIPS routines:FIPS_mode_set:fingerprint does not match


Attention: This message and all attachments are private and may contain
information that is confidential and privileged. If you received this
message in error, please notify the sender by reply email and delete
the message immediately.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20120229/dc410979/attachment.html>

More information about the stunnel-users mailing list