[stunnel-users] stunnel version 4.53 says SSL server needs a certificate on Windows 7?

Ludolf Holzheid lholzheid at bihl-wiedemann.de
Wed Jun 13 20:37:12 CEST 2012

On Wed, 2012-06-13 14:05:23 -0400, Wayne Walter wrote:
> I have been using stunnel previous versions just fine. It didn't apparently
> have the feature of a certificate in SSL server mode. That's alright but
> not necessary for us as we're simply running a localhost server to tunnel
> to the remote server.
> Anyway, I have read the FAQ tutorial and such related to this and tried
> everything. No mater what I do with the cert or key settings it still gives
> this same error here's the complete output....
> No limit detected for the number of clients
> stunnel 4.53 on x86-pc-mingw32-gnu platform
> Compiled/running with OpenSSL 0.9.8s-fips 4 Jan 2012
> Threading:WIN32 SSL:+ENGINE+OCSP+FIPS Auth:none Sockets:SELECT+IPv6
> Reading configuration from file stunnel.conf
> FIPS mode is enabled
> [..]


I don't really know much about FIPS, but as far as I understood,
FIPS 186-3, amongst other things, defines a subset of encryption
methods that are believed to be secure.  Maybe the certificate in your
stunnel.pem does not meet the criteria of the US government.

You could try to disable FIPS.



Ludolf Holzheid             Tel:    +49 621 339960
Bihl+Wiedemann GmbH         Fax:    +49 621 3392239
Floßwörthstraße 41          e-mail: lholzheid at bihl-wiedemann.de
D-68199 Mannheim, Germany

More information about the stunnel-users mailing list