[stunnel-users] stunnel version 4.53 says SSL server needs a certificate on Windows 7?

Wayne Walter waynewalter at tickzoom.com
Wed Jun 13 20:05:23 CEST 2012

I have been using stunnel previous versions just fine. It didn't apparently
have the feature of a certificate in SSL server mode. That's alright but
not necessary for us as we're simply running a localhost server to tunnel
to the remote server.

Anyway, I have read the FAQ tutorial and such related to this and tried
everything. No mater what I do with the cert or key settings it still gives
this same error here's the complete output....

No limit detected for the number of clients
stunnel 4.53 on x86-pc-mingw32-gnu platform
Compiled/running with OpenSSL 0.9.8s-fips 4 Jan 2012
Threading:WIN32 SSL:+ENGINE+OCSP+FIPS Auth:none Sockets:SELECT+IPv6
Reading configuration from file stunnel.conf
FIPS mode is enabled
Compression not enabled
Snagged 64 random bytes from C:/.rnd
Wrote 0 new random bytes to C:/.rnd
PRNG seeded successfully
Initializing service section [FIX]
Section FIX: SSL server needs a certificate

Server is down

And here is the stunnel.conf file contents:

; Certificate/key is needed in server mode and optional in client mode
cert = stunnel.pem
;key = stunnel.pem

; Disable support for insecure SSLv2 protocol
options = NO_SSLv2

accept  =
connect =
TIMEOUTconnect = 5

accept  =
connect =
TIMEOUTconnect = 5

Please not that stunnel came installed with an stunnel.pem file. I tried
uncommenting the config line for the key. Also regenerated the key using
openssh per instructions.

I tried using absolute path to the cert file.

Nothing makes any difference. Is this a defect in stunnel? Or am I doing
something wrong?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20120613/8714edaf/attachment.html>

More information about the stunnel-users mailing list