[stunnel-users] MySQL replication + SSL/stunnel

Gareth Evans garethevans at fastmail.fm
Mon Aug 27 20:12:18 CEST 2012


I'm failing miserably to implement replication over any kind of SSL (that is, MySQL's native (alleged) SSL support) or stunnel.  I'd be grateful for any tips or advice.

I have tried using OpenSSL and MySQL in various flavours:

CentOS 6.2, OpenSSL v1.0.0, MySQL v5.1.63
Ubuntu 12.04, OpenSSL v1.0.1, MySQL v 5.5.24

and stunnel4 on both - certs created with OpenSSL in each case.

I get an eror 1045 access denied from the MySQL native SSL approach, and

mysql -u ejbkslave -pejbkslavepw -h127.0.0.1 -P3307
ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 104

from stunnel (connecting two Ubuntu 12.04 VM's on my PC, with the latest updates) - if you know what causes this error and/or could point me towards some good documentation, I'd be grateful.

I've copied and amended stunnel.conf-sample and just added debug and accept/connect info in each case.
I've seen various reports around the web that OpenSSL+MySQL don't work together at the moment, but it seems some people can repicate the problem while others can't - I've tried the previous version of OpenSSL (1.0.0e on Ubuntu) still without success.  

Most frustrating!!


More information about the stunnel-users mailing list