[stunnel-users] stunnel claims it needs certificate

JOSE jtc at totaltravelmarketing.com
Wed Sep 14 21:50:55 CEST 2011


I am trying to get stunnel stunnel 4.36 on ia64-hp-hpux11.23 with 
OpenSSL 0.9.8o 01 Jun 2010 working on this server and so far I have 
generated a new pem file as per the instructions, but it is the time to 
make to run, it keeps looking for a certificate for one of the services:

bash-3.2# /opt/iexpress/stunnel/bin/stunnel 
Reading configuration from file 
Snagged 64 random bytes from /opt/iexpress/stunnel/etc/stunnel/stunnel.rnd
Wrote 1024 new random bytes to /opt/iexpress/stunnel/etc/stunnel/stunnel.rnd
PRNG seeded successfully
Line 37: End of section revnet_preprod_sunquest: SSL server needs a 

my conf file is as follows:
bash-3.2# more /opt/iexpress/stunnel/etc/stunnel/stunnel.conf
# Sample stunnel configuration file

# Chroot
#chroot = /var/chroot/stunnel/

# PID is created inside chroot jail
#pid = /opt/hpws/apache/logs/stunnel.pid
pid = /opt/iexpress/stunnel/etc/stunnel/stunnel.pid
# Workaround for Eudora bug

# Client Authentication
#verify = 2
# don't forget about c_rehash CApath
# it is located inside chroot jail:
#CApath = /certs
# or simply use CAfile instead:
#CAfile = /opt/hpws/apache/conf/certs.pem

# Some debugging stuff
debug = 7
output = /opt/hpws/apache/logs/stunnel.log

# Use in client mode
client = no

# Run in the background
foreground = no

# Service-level configuration
accept  =
connect =
#connect = 18011

accept  =
connect =
#connect = 18017

any help or tips would be welcome



More information about the stunnel-users mailing list