[stunnel-users] Internal error after reload modified server mode section

Peter Pentchev roam at ringlet.net
Wed Sep 7 17:02:27 CEST 2011

On Tue, Sep 06, 2011 at 04:55:59PM +0200, Michal Trojnara wrote:
> Javier wrote:
> >What is happening is that, after change the server section in the
> >config file (the rest are all client mode), if it has been any
> >connection to that server (and only if it has been a connection),
> >when
> >I reload the modified conf, it gives...:
> >
> >INTERNAL ERROR: get_alloc_list_ptr: Bad magic
> >str_stats: 380 block(s), 96684 byte(s)
> [cut]
> >What I'm doing wrong? Is the normal behavior? Is it a new bug?
> It was a new bug.  Please install:
> ftp://ftp.stunnel.org/stunnel/stunnel-4.43b1-installer.exe
> and let us know if it works for you.

Just out of interest, is this a Windows-specific bug or would it also
affect, say, the FreeBSD port of stunnel that I'm just about to update
to 4.42?

Thanks for your work on stunnel!


Peter Pentchev	roam at ringlet.net roam at FreeBSD.org peter at packetscale.com
PGP key:	http://people.FreeBSD.org/~roam/roam.key.asc
Key fingerprint	FDBA FD79 C26F 3C51 C95E  DF9E ED18 B68D 1619 4553
Do you think anybody has ever had *precisely this thought* before?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20110907/8f8d82af/attachment.sig>

More information about the stunnel-users mailing list