[stunnel-users] Compression

Ludovic LEVET llevet at ludosoft.org
Sat Dec 10 14:57:18 CET 2011


So, i understand that the methode  : 
sk_SSL_COMP_zero(SSL_COMP_get_compression_methods()); will work for 
0.9.8 and 1.0.0 openssl.'

So, on my server, i can compile version 4.51 on my linux box who have 
openssl 1.0.0 by default ant it will work (for global connection), i'm 
just haven't the possibility
to disable compression per-connection (lack of  SSL_CTX_set_options), 
but it is perfect for me.


Le 10/12/2011 07:52, Michal Trojnara a écrit :
> Ludovic LEVET wrote:
>> For your next version (> 4.51) with update code for compression, i 
>> will replace openssl 0.9.8 by openssl 1.0.0e given from package 4.47 
>> (for
>> windows of course) then i'm will be able to control compression (but 
>> am lost FIPS, not very important for me).
>> This is possible ?  (i think...)
> 1. This is not possible, as OpenSSL 0.9.8 shared library (DLLs) is not 
> binary-compatible with OpenSSL 1.0.0 shared library.
> 2. This won't be needed, as compression control in stunnel 4.51 will 
> also work with OpenSSL 0.9.8.
> Mike 

More information about the stunnel-users mailing list