[stunnel-users] Installing Stunnel 4.21 on Shared Hosting Server with OpenSSL 0.9.6g

Norbert Hoeller nhoeller at sinet.ca
Sun Feb 17 19:11:19 CET 2008

Gonzalo, thanks for the fast response.  I downloaded the 
openssl-0.9.6g.tar.gz package, extracted it and ran "./configure 
--with-ssl=...openssl-0.9.6g".  "make" still failed with the same error as 

I noticed some messages about not finding "engine.h", so I downloaded, 
extracted and pointed --with-ssl to "...openssl-engine-0.9.6g".  "make" 
still failing with "common.h:318: #error OpenSSL library compiled without 
thread support".

I will dig some more into what it takes to install the OpenSSL development 
package, although I suspect that the shared hosting environment I am using 
will seriously limit what I can do.
        Regards, Norbert

Gonzalo Diethelm <gonzalo.diethelm at diethelm.org> 
16/02/2008 11:58 PM

Norbert Hoeller <nhoeller at sinet.ca>
stunnel-users at mirt.net
Re: [stunnel-users] Installing Stunnel 4.21 on Shared Hosting   Server 
with OpenSSL 0.9.6g

PHP indicates that the OpenSSL runtime libraries and executables are 
installed. In order to compile, you need the OpenSSL development package.

Hope that helps. Best regards.

On Sat, 2008-02-16 at 12:42 -0500, Norbert Hoeller wrote:

I am trying to install Stunnel 4.21 on a 1&1 shared Linux server.  PHP 
Settings claims that OpenSSL 0.9.6g is installed.  I unpacked the tar file 
and ran "./configure" using --prefix to override the /usr/local/ install 
directory.  I had one warning: "configure: WARNING: Openssl engine header 
not found".  In terms of threading model, I got "configure: PTHREAD thread 
model detected". 

When I tried to run "make", I got "common.h:318: #error OpenSSL library 
compiled without thread support".  Is there a way around this?  I tried 
running "./configure" with --with-threads=ucontext/fork, but that gave a 
bunch of "OCSP_" undeclared variables and "Error 1". 
        Thanks, Norbert 

stunnel-users mailing list
stunnel-users at mirt.net

Gonzalo Diethelm
gonzalo.diethelm at diethelm.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20080217/0fdc3e87/attachment.html>

More information about the stunnel-users mailing list