[stunnel-users] Installing Stunnel 4.21 on Shared Hosting Server with OpenSSL 0.9.6g

Norbert Hoeller nhoeller at sinet.ca
Sat Feb 16 18:42:43 CET 2008

I am trying to install Stunnel 4.21 on a 1&1 shared Linux server.  PHP 
Settings claims that OpenSSL 0.9.6g is installed.  I unpacked the tar file 
and ran "./configure" using --prefix to override the /usr/local/ install 
directory.  I had one warning: "configure: WARNING: Openssl engine header 
not found".  In terms of threading model, I got "configure: PTHREAD thread 
model detected".

When I tried to run "make", I got "common.h:318: #error OpenSSL library 
compiled without thread support".  Is there a way around this?  I tried 
running "./configure" with --with-threads=ucontext/fork, but that gave a 
bunch of "OCSP_" undeclared variables and "Error 1".
        Thanks, Norbert
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20080216/176eb608/attachment.html>

More information about the stunnel-users mailing list