[stunnel-users] error 1703, service already exists.

Carter Browne cbrowne at cbcs-usa.com
Fri Oct 20 18:35:47 CEST 2006


In Windows, install here means install as a service which only needs to be done once.  The install option does not start 
up stunnel, it can be done by using the windows CLI command

net start stunnel

or will happen automatically when you restart your computer.

The TCP addresses and ports that stunnel processes are defined in your configuration file.

You can tell stunnel is working by either using the taskmgr (for all users) or by using the services management menu in 
the administrative tools section of the control panel.


Joop Blokker wrote:
> Hello,
> I'm using sTunnel v4.18 under Windows XP as a client. I start the 
> service with sTunnel -install -quiet
> If, for any reason, the same command is given again then the error 
> message "Create service; error 1703; the specified service already 
> exists" pops up. In that case the -quiet parameter does not work. I do 
> not want to see that error message; if the service is running then it's 
> okay.
> Q:. How can I suppress that error message?  If that is not an option, 
> how can I detect that the sTunnel service is installed already?
> I'm programming in PowerBASIC - I know how to detect sTunnel once it has 
> started with -start -quiet
> Thanks in advance for any idea!
> Joop.
> +++ Too far East is West. - Proverb (English) +++
> ------------------------------------------------------------------------
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at mirt.net
> http://stunnel.mirt.net/mailman/listinfo/stunnel-users
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cbrowne.vcf
Type: text/x-vcard
Size: 220 bytes
Desc: not available
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20061020/b8eb8240/attachment.vcf>

More information about the stunnel-users mailing list