[stunnel-users] Configure can't find openssl in Ubuntu

Eric S. Eberhard flash at vicsmba.com
Tue Oct 3 18:42:54 CEST 2006

The problem with stunnel is that you are using a 4.x configuration 
file with a 3.x stunnel.  3.x stunnel uses switches (not .conf file) 
... 4.x changed from switches.  You could simply install the 4.x -- 
it supports later SSL versions (2 & 3) and seems to work pretty well 
-- I just went through this.

At 07:16 AM 10/3/2006, you wrote:
>You probably need something like libcurl3-openssl-dev as well. Probably...
>On Tue, 2006-10-03 at 16:40 +0300, Tommi Nieminen wrote:
>>I have an Ubuntu 6.06.1 (Dapper) where I'm trying to install
>>Stunnel. First I tried to install Stunnel using Ubuntu's
>>package manager (apt-get install stunnel4). The installation
>>went very smoothly but the fact that stunnel didn't recognize
>>the -V switch left me with an uneasy feeling that something
>>else might be lacking, too. The Ubuntu package in question
>>contains Stunnel 4.14. Stunnel 3.26, installed from another
>>package, does recognize the -V switch.
>>So then I tried several times installing stunnel from source.
>>A few obstacles I managed to overcome, but now that the
>>configure script stops telling that it can't find SSL directory
>>   checking for SSL directory... Not found
>>   Couldn't find your SSL library installation dir
>>   Use --with-ssl option to fix this problem
>>I'm out of resources. The script seems to check the existence
>>of ssl.h file:
>>   checkssldir() { :
>>     if test -f "$1/include/openssl/ssl.h"
>>Despite the fact that I have OpenSSL 0.9.8a on my machine,
>>I don't have ssl.h file anywhere, I checked that with find.
>>I tried installing Linux headers, but that didn't help (well
>>I didn't expect it to help, but I couldn't think of anything).
>>Is there some package I should get, that doesn't come with the
>>openssl package or how should I solve this problem? Any ideas?
>>Another problem that I had when I was experimenting with
>>Stunnel 3.26 was the fact, that I couldn't start it up.
>>It kept asking for the -r or -l switch. What I want to do
>>with Stunnel is to decrypt the traffic coming in on one
>>interface and then forward it to another machine through
>>another interface. I tried several different configuration
>>files, this is one of them (without indentations):
>>   cert = stunnel.pem
>>   key = stunnel.pem
>>   socket = l:TCP_NODELAY=1
>>   socket = r:TCP_NODELAY=1
>>   verify = 1
>>   debug = 7
>>   output = stunnel.log
>>   client = no
>>   [https]
>>   accept  = 443
>>   connect =
>>   TIMEOUTclose = 0
>>I didn't get any debug information and -f switch didn't
>>give anything more. I tried the Windows version (4.18)
>>on another pc and it seemed to do exactly what I wanted.
>>(the config file may have been slightly different, at
>>least no debug was set. I really would like to get this
>>working on a Linux box, too.
>>Tommi Nieminen
>>stunnel-users mailing list
>><mailto:stunnel-users at mirt.net>stunnel-users at mirt.net
>Gonzalo Diethelm
>gonzalo.diethelm at aditiva.com
>stunnel-users mailing list
>stunnel-users at mirt.net

This email sent by:

Eric S. Eberhard
(928) 567-3727          Voice
(928) 567-6122          Fax

928-301-7537 -- you may call any time day or night, I turn it off 
when I sleep :-)  Please try to use a land line first (reception often poor).

Note the change in the domain from vicspdi.com to vicsmba.com !!!!

For Metropolis support and VICS MBA Support!!!!


Completely updated web site of personal pictures with many new 
pictures!  Includes horses, dogs, Corvairs, and more.


Corvair pictures including the Judson setup on our 62 Sedan and lots 
of pictures of Cheryl's 62 Monza Wagon and our 62 Spyder convertible.


My younger brother Martin has started a very serious car company.  A 
hot rod (very fast) electric roadster is the first offering.  The 
chassis is built by Lotus to their specs.  Check it 
out:  http://www.teslamotors.com

More information about the stunnel-users mailing list