[stunnel-users] Configure can't find openssl in Ubuntu

Tommi Nieminen ttn at mbnet.fi
Tue Oct 3 15:40:08 CEST 2006


I have an Ubuntu 6.06.1 (Dapper) where I'm trying to install
Stunnel. First I tried to install Stunnel using Ubuntu's
package manager (apt-get install stunnel4). The installation
went very smoothly but the fact that stunnel didn't recognize
the -V switch left me with an uneasy feeling that something
else might be lacking, too. The Ubuntu package in question
contains Stunnel 4.14. Stunnel 3.26, installed from another
package, does recognize the -V switch.

So then I tried several times installing stunnel from source.
A few obstacles I managed to overcome, but now that the
configure script stops telling that it can't find SSL directory

  checking for SSL directory... Not found

  Couldn't find your SSL library installation dir
  Use --with-ssl option to fix this problem

I'm out of resources. The script seems to check the existence
of ssl.h file:

  checkssldir() { :
    if test -f "$1/include/openssl/ssl.h"

Despite the fact that I have OpenSSL 0.9.8a on my machine,
I don't have ssl.h file anywhere, I checked that with find.
I tried installing Linux headers, but that didn't help (well
I didn't expect it to help, but I couldn't think of anything).

Is there some package I should get, that doesn't come with the
openssl package or how should I solve this problem? Any ideas?

Another problem that I had when I was experimenting with
Stunnel 3.26 was the fact, that I couldn't start it up.
It kept asking for the -r or -l switch. What I want to do
with Stunnel is to decrypt the traffic coming in on one
interface and then forward it to another machine through
another interface. I tried several different configuration
files, this is one of them (without indentations):

  cert = stunnel.pem
  key = stunnel.pem

  socket = l:TCP_NODELAY=1
  socket = r:TCP_NODELAY=1

  verify = 1

  debug = 7
  output = stunnel.log

  client = no

  accept  = 443
  connect =
  TIMEOUTclose = 0

I didn't get any debug information and -f switch didn't
give anything more. I tried the Windows version (4.18)
on another pc and it seemed to do exactly what I wanted.
(the config file may have been slightly different, at
least no debug was set. I really would like to get this
working on a Linux box, too.

Tommi Nieminen

More information about the stunnel-users mailing list