[stunnel-users] How use certificates with stunnel -- Newbie question

Shatadal shatadal at vfemail.net
Sun Nov 28 12:21:07 CET 2004

mtrojnar at mirt wrote:
> Shatadal wrote:
>>I tried your second suggestion (myisp has port 465 disabled)
>>but it did not work.
> Are you *sure* your ISP supports encrypted SMTP?
> Does it work with any other client?

I think I have solved my problem. It was being caused by my mail scanner 
Alwil Avast. Once I stopped the mail scanning module stunnel is being 
able to send my e-mail except for a small problem. Though my e-mail 
client (thunderbird)is able to send the message it gives an error:

The current command did not succeed. The mail server responded: APPEND 
failed: Error finishing scratch file: No space left on device.

This is probably nothing to do with stunnel, but if you could explain it 
to me, it would be very helpful.

The stunnel log is:

2004.11.28 05:12:15 LOG5[2140:2284]: myisp-smtps-ssl connected from
2004.11.28 05:12:15 LOG5[2140:2284]: Negotiations for smtp (client side) 
2004.11.28 05:12:20 LOG5[2140:2284]: Protocol negotiation succeeded
2004.11.28 05:12:21 LOG3[2140:2284]: SSL_read (ERROR_SYSCALL): 
Connection reset by peer (WSAECONNRESET) (10054)
2004.11.28 05:12:21 LOG5[2140:2284]: Connection reset: 703 bytes sent to 
SSL, 541 bytes sent to socket

> Best regards,
>     Mike

Thanks for the help,

avast! Antivirus: Outbound message clean.
Virus Database (VPS): 0448-1, 11/26/2004
Tested on: 11/28/2004 5:21:08 AM
avast! - copyright (c) 2000-2004 ALWIL Software.

More information about the stunnel-users mailing list