[stunnel-users] SSL Engine patch on Windows?

Kartik Subbarao subbarao at computer.org
Fri Nov 12 03:28:09 CET 2004

Kartik Subbarao wrote:
> But when I run stunnel, I get errors with dynamic library loading like:
> error stack: 260B6084 : error:260B6084:engine routines:DYNAMIC_LOAD:dso 
> not found

Ok -- I got past this particular issue (I needed to add more options and 
make an allowance for the LOAD command not having an argument).

But now I've run into another issue. stunnel on Windows is a GUI app, 
but the OpenSC engine_pkcs11.dll needs to prompt for the SmartCard PIN 
as a text input. When I run stunnel, it just goes into an infinite loop 
(most likely because the OpenSC code has an infinite loop where it 
prompts for the PIN until it gets it).

I'll ask the OpenSC folks for advice from their side, but I was 
wondering if there was any way, as a workaround, to disable the GUI and 
just make stunnel run interactively on the command line on Windows.

Thanks for any suggestions.


More information about the stunnel-users mailing list