<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css" style="display:none"><!-- p { margin-top: 0px; margin-bottom: 0px; }--></style>
</head>
<body dir="ltr" style="font-size:12pt;color:#000000;background-color:#FFFFFF;font-family:Calibri,Arial,Helvetica,sans-serif;">
<p>Hi Mike,<br>
</p>
<p><br>
</p>
<p>yes your correct, but I have forced the installation with "stunnel-4.29-3.el6_4.x86_64" ( all other packages openssl, etc. updated) and SSLv3 is working again.<br>
</p>
<p><br>
</p>
<p>So, for my understanding there must be a bug or they have disabled SSLv3 in version "<span style="font-size: 12pt;">stunnel-4.29-3.el6_6.1.x86_64".</span></p>
<p><span style="font-size: 12pt;"><br>
</span></p>
<p><span style="font-size: 12pt;">Regards,</span></p>
<p><span style="font-size: 12pt;">Sebastian.</span></p>
<p><br>
</p>
<p><br>
</p>
<p><br>
</p>
<p><br>
</p>
<div style="color: rgb(33, 33, 33);">
<hr tabindex="-1" style="display:inline-block; width:98%">
<div id="divRplyFwdMsg" dir="ltr"><font face="Calibri, sans-serif" color="#000000" style="font-size:11pt"><b>Von:</b> stunnel-users <stunnel-users-bounces@stunnel.org> im Auftrag von Michal Trojnara <Michal.Trojnara@mirt.net><br>
<b>Gesendet:</b> Donnerstag, 29. Januar 2015 12:12<br>
<b>An:</b> stunnel-users@stunnel.org<br>
<b>Betreff:</b> Re: [stunnel-users] Centos 6.6 Final stunnel-4.29-3.el6_6.1.x86_64 - options set problem SSLv3</font>
<div> </div>
</div>
<div>Hi Sebastian,<br>
<br>
The ChangeLog does not say anything about disabling SSLv3:<br>
<a class="moz-txt-link-freetext" href="http://rpmfind.net/linux/RPM/centos/updates/6.6/x86_64/Packages/stunnel-4.29-3.el6_6.1.x86_64.html">http://rpmfind.net/linux/RPM/centos/updates/6.6/x86_64/Packages/stunnel-4.29-3.el6_6.1.x86_64.html</a><br>
I guess it may be disabled in the OpenSSL rather than in stunnel.<br>
<br>
Anyway, if you connect stunnel with some software that's so old that it doesn't support TLS, the software is almost certainly no longer supported, and most likely vulnerable to attacks.  This is a serious risk!<br>
<br>
Mike<br>
<br>
<div class="moz-cite-prefix">On 29.01.2015 11:58, Sebastian Ochsenkühn wrote:<br>
</div>
<blockquote type="cite"><style type="text/css" style="">
<!--
p
        {margin-top:0px;
        margin-bottom:0px}
-->
</style>
<p>Hi Mike,<br>
</p>
<p><br>
</p>
<p>thanks for your fast response, but I think there is a big issue.<br>
</p>
<p>The latest version that is available in the CENTOS 6 Base Repo is "<span style="font-size:12pt">stunnel-4.29-3.el6_6.1.x86_64"  - In this version the SSLv3 is disabled by default, but there is not option to enable it.</span></p>
<p><span style="font-size:12pt"><br>
</span></p>
<p>I hope you understand my situation :-) <br>
</p>
<p><br>
</p>
<p><br>
</p>
<p><br>
</p>
<p><br>
</p>
<div style="color:rgb(33,33,33)">
<hr tabindex="-1" style="display:inline-block; width:98%">
<div id="divRplyFwdMsg" dir="ltr"><font color="#000000" face="Calibri, sans-serif" style="font-size:11pt"><b>Von:</b> stunnel-users
<a class="moz-txt-link-rfc2396E" href="mailto:stunnel-users-bounces@stunnel.org">
<stunnel-users-bounces@stunnel.org></a> im Auftrag von Michal Trojnara <a class="moz-txt-link-rfc2396E" href="mailto:Michal.Trojnara@mirt.net">
<Michal.Trojnara@mirt.net></a><br>
<b>Gesendet:</b> Donnerstag, 29. Januar 2015 11:44<br>
<b>An:</b> <a class="moz-txt-link-abbreviated" href="mailto:stunnel-users@stunnel.org">
stunnel-users@stunnel.org</a><br>
<b>Betreff:</b> Re: [stunnel-users] Centos 6.6 Final stunnel-4.29-3.el6_6.1.x86_64 - options set problem SSLv3</font>
<div> </div>
</div>
<div>Hi Sebastian,<br>
<br>
My documentation describes the latest version of stunnel.  For an old version please refer to the appropriate manual page distributed with the specific version you're using.<br>
<br>
Mike<br>
<br>
<div class="moz-cite-prefix">On 29.01.2015 11:40, Sebastian Ochsenkühn wrote:<br>
</div>
<blockquote type="cite"><style type="text/css" style="">
<!--
p
        {margin-top:0px;
        margin-bottom:0px}
-->
</style>
<p>Hi,<br>
</p>
<p><br>
</p>
<p>I have a big problem with the new stunnel version on CentOS 6.6 (stunnel-4.29-3.el6_6.1.x86_64) that is available in the CentOS base repository.<br>
</p>
<p><br>
</p>
<p>You describe in your documentation that SSLv3 is disabled by default.  -> OK for me, but I need SSLv3 and the option with -NO_SSLv3 is not working​!<br>
</p>
<p>PS: this is also not working with -NO_SSLv2 option.<br>
</p>
<p><br>
</p>
<p>options = -NO_SSLv3 = NOT Working<br>
</p>
<p><br>
</p>
<p>option = NO_SSLv3 = Working.<br>
</p>
<p><br>
</p>
<p>Currently i have installed an older version, where the SSLv3 protocoll is not disabled by default.<br>
</p>
<p><br>
</p>
<p>Is there anything that I'm doing wrong? <br>
</p>
<p><br>
</p>
<p>Thanks and Regards,<br>
</p>
<p>Sebastian.<br>
</p>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset> <br>
<pre>_______________________________________________
stunnel-users mailing list
<a class="moz-txt-link-abbreviated" href="mailto:stunnel-users@stunnel.org">stunnel-users@stunnel.org</a>
<a class="moz-txt-link-freetext" href="https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users">https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users</a>
</pre>
</blockquote>
<br>
</div>
</div>
</blockquote>
<br>
</div>
</div>
</body>
</html>