<p>I didn't see a port setting in the clients stunnel.conf</p>
<div class="gmail_quote">On Nov 16, 2012 6:18 PM, "Hal Hovland" <<a href="mailto:hhovland@btconnect.com">hhovland@btconnect.com</a>> wrote:<br type="attribution"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div lang="EN-GB" link="blue" vlink="purple"><div><p class="MsoNormal">Iíve spent days googling this and read everything relevant in the archives.<u></u><u></u></p><p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">
Iím developing a Windows 7 program that connects to a financial trading exchange that expects all communication to be SSLíd. Everything I read said that stunnel is the answer because of ease of installation and use. After a day of abortive attempts to link to the exchange, I decided to create a much simpler test environment involving two Windows 7 computers next to each other here.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">One, letís call it Riven-II (192.168.1.9), is set up with a simple Listener program that listens on port 8000. From stunnelís viewpoint this will be a server. The second machine, Lightning (192.168.1.158), has a simple Sender program that sends a text message via port 7999 to Riven-II (<a href="http://192.168.1.9:8000" target="_blank">192.168.1.9:8000</a>) Ė this will be the Client. In the absence of stunnel, all messages sent from Lightning/Sender appears on the window of Listener. So far so good.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">Iíve downloaded and installed the very latest version (4.54) of stunnel on both machines. On installation I entered the same responses to the certificate generating process.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">On the Server machine, hard wired to a Broadband Router, I configured stunnel.conf as (removing comments for simplicity)<u></u><u></u></p><p class="MsoNormal"><u></u>†<u></u></p>
<p class="MsoNormal"><i>debug = 7<u></u><u></u></i></p><p class="MsoNormal"><i>output = stunnel.log<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>socket = l:TCP_NODELAY=1<u></u><u></u></i></p>
<p class="MsoNormal"><i>socket = r:TCP_NODELAY=1<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>cert = stunnel.pem<u></u><u></u></i></p><p class="MsoNormal"><i>key = stunnel.pem<u></u><u></u></i></p>
<p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>options = NO_SSLv2<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>taskbar=yes<u></u><u></u></i></p><p class="MsoNormal">
<i><u></u>†<u></u></i></p><p class="MsoNormal"><i>[Listener]<u></u><u></u></i></p><p class="MsoNormal"><i>connect=8000<u></u><u></u></i></p><p class="MsoNormal"><i>accept=8001<u></u><u></u></i></p><p class="MsoNormal"><u></u>†<u></u></p>
<p class="MsoNormal">On the Client machine, connected to the router via wi-fi, we have in stunnel.conf<u></u><u></u></p><p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal"><i>debug = 7<u></u><u></u></i></p><p class="MsoNormal">
<i>output = stunnel.log<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>cert = stunnel.pem<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal">
<i>socket = l:TCP_NODELAY=1<u></u><u></u></i></p><p class="MsoNormal"><i>socket = r:TCP_NODELAY=1<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>fips=no<u></u><u></u></i></p><p class="MsoNormal">
<i><u></u>†<u></u></i></p><p class="MsoNormal"><i>options = NO_SSLv2<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>delay=yes<u></u><u></u></i></p><p class="MsoNormal"><i>taskbar=yes<u></u><u></u></i></p>
<p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>client=yes<u></u><u></u></i></p><p class="MsoNormal"><i><u></u>†<u></u></i></p><p class="MsoNormal"><i>[sender]<u></u><u></u></i></p><p class="MsoNormal">
<i>accept† = <a href="http://0.0.0.0:7999" target="_blank">0.0.0.0:7999</a>†††††† (Iíve tried just 7999 and <a href="http://192.168.1.158:7999" target="_blank">192.168.1.158:7999</a>, here. Makes no difference)<u></u><u></u></i></p>
<p class="MsoNormal"><i>connect = <a href="http://192.168.1.9:8001" target="_blank">192.168.1.9:8001</a><u></u><u></u></i></p><p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">Iíve tried many variations with the same result, but the above is where they have ended up.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">My understanding of this is that stunnel both ends will be intercepting port 8000 on the Server and port 7999 on the Client and presenting/receiving SSL encoded messages across the wire on port 8001.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">Starting stunnel in the Server† (not as a Windows service, although I did try that as well) the following log appears:<u></u><u></u></p><p class="MsoNormal"><u></u>†<u></u></p>
<p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG7[3484:6184]: No limit detected for the number of clients<u></u><u></u></i></p><p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG5[3484:6184]: stunnel 4.54 on x86-pc-msvc-1500 platform<u></u><u></u></i></p>
<p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG5[3484:6184]: Compiled/running with OpenSSL 1.0.1c-fips 10 May 2012<u></u><u></u></i></p><p class="MsoNormal">
<i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG5[3484:6184]: Threading:WIN32 SSL:+ENGINE+OCSP+FIPS Auth:none Sockets:SELECT+IPv6<u></u><u></u></i></p><p class="MsoNormal">
<i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG5[3484:6184]: Reading configuration from file stunnel.conf<u></u><u></u></i></p><p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG5[3484:6184]: FIPS mode is enabled<u></u><u></u></i></p>
<p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG7[3484:6184]: Compression not enabled<u></u><u></u></i></p><p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG7[3484:6184]: Snagged 64 random bytes from C:/.rnd<u></u><u></u></i></p>
<p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG7[3484:6184]: Wrote 1024 new random bytes to C:/.rnd<u></u><u></u></i></p><p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG7[3484:6184]: PRNG seeded successfully<u></u><u></u></i></p>
<p class="MsoNormal"><i><a href="tel:2012.11.16%2022" value="+12012111622" target="_blank">2012.11.16 22</a>:34:08 LOG6[3484:6184]: Initializing service [Listener]<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: Certificate: stunnel.pem<u></u><u></u></i></p>
<p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: Certificate loaded<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: Key file: stunnel.pem<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:34:08 LOG7[3484:6184]: Private key loaded<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: Could not load DH parameters from stunnel.pem<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:34:08 LOG7[3484:6184]: Using hardcoded DH parameters<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: DH initialized with 2048-bit key<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:34:08 LOG7[3484:6184]: ECDH initialized with curve prime256v1<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: SSL options set: 0x01000004<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:34:08 LOG5[3484:6184]: Configuration successful<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:34:08 LOG7[3484:6184]: Service [Listener] (FD=272) bound to <a href="http://0.0.0.0:8001" target="_blank">0.0.0.0:8001</a><u></u><u></u></i></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">On the Client, the log shows:<u></u><u></u></p><p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: No limit detected for the number of clients<u></u><u></u></i></p>
<p class="MsoNormal"><i>2012.11.16 22:25:53 LOG5[4184:4948]: stunnel 4.54 on x86-pc-msvc-1500 platform<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG5[4184:4948]: Compiled/running with OpenSSL 1.0.1c-fips 10 May 2012<u></u><u></u></i></p>
<p class="MsoNormal"><i>2012.11.16 22:25:53 LOG5[4184:4948]: Threading:WIN32 SSL:+ENGINE+OCSP+FIPS Auth:none Sockets:SELECT+IPv6<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG5[4184:4948]: Reading configuration from file stunnel.conf<u></u><u></u></i></p>
<p class="MsoNormal"><i>2012.11.16 22:25:53 LOG5[4184:4948]: FIPS mode is disabled<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: Compression not enabled<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:25:53 LOG7[4184:4948]: Snagged 64 random bytes from C:/.rnd<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: Wrote 1024 new random bytes to C:/.rnd<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:25:53 LOG7[4184:4948]: PRNG seeded successfully<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG6[4184:4948]: Initializing service [sender]<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: Certificate: stunnel.pem<u></u><u></u></i></p>
<p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: Certificate loaded<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: Key file: stunnel.pem<u></u><u></u></i></p><p class="MsoNormal">
<i>2012.11.16 22:25:53 LOG7[4184:4948]: Private key loaded<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: SSL options set: 0x01000004<u></u><u></u></i></p><p class="MsoNormal"><i>2012.11.16 22:25:53 LOG5[4184:4948]: Configuration successful<u></u><u></u></i></p>
<p class="MsoNormal"><i>2012.11.16 22:25:53 LOG7[4184:4948]: Service [sender] (FD=224) bound to <a href="http://0.0.0.0:7999" target="_blank">0.0.0.0:7999</a> <u></u><u></u></i></p><p class="MsoNormal"><u></u>†<u></u></p>
<p class="MsoNormal">Running the Listener on the Server and Sender on the Client adds nothing to the log, and port sniffers on both machines show traffic between 7999 and 8000 (exactly the same as when stunnel is not running). No sign of the use of port 8001.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">Iíd appreciate any input on this. Iím sure I must be doing something stupid, but Iíve watched hours of YouTube videos, read many hundreds of web pages, and been through the documentation quite a few times, to no avail.<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">I have a Java based version, running in a JVM in the same Windows machines, that talks perfectly to the exchange using some inbuilt SSL capabilities of an included library, so that should probably eliminate any hardware/router issues?<u></u><u></u></p>
<p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal">Regards, Hal<u></u><u></u></p><p class="MsoNormal"><u></u>†<u></u></p><p class="MsoNormal"><u></u>†<u></u></p></div></div><br>_______________________________________________<br>

stunnel-users mailing list<br>
<a href="mailto:stunnel-users@stunnel.org">stunnel-users@stunnel.org</a><br>
<a href="https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users" target="_blank">https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users</a><br>
<br></blockquote></div>