> And just comment the line that includes applink.c in stunnel.c<br>That was not obvious :)<br><br>Thank you Jose, it finally works!!!<br><br><div class="gmail_quote">2012/8/1  <span dir="ltr"><<a href="mailto:josealf@rocketmail.com" target="_blank">josealf@rocketmail.com</a>></span><br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><u></u><div>Anton,<br><br>Do not run configure stunnel. Not required. After your openssl is compiled, Just edit mingw.mak. You also need to set the SSLDIR (I guess you did ;) ...<br>

And just comment the line that includes applink.c in stunnel.c<br><br>Regards,<br><br>Jose<hr><div><b>From: </b> Anton Tkachev <<a href="mailto:anton.tkachev@gmail.com" target="_blank">anton.tkachev@gmail.com</a>>
</div><div><b>Date: </b>Wed, 1 Aug 2012 15:54:45 +0700</div><div><b>To: </b>Jose Alf.<<a href="mailto:josealf@rocketmail.com" target="_blank">josealf@rocketmail.com</a>></div><div><b>Cc: </b><a href="mailto:stunnel-users-bounces@stunnel.org" target="_blank">stunnel-users-bounces@stunnel.org</a><<a href="mailto:stunnel-users-bounces@stunnel.org" target="_blank">stunnel-users-bounces@stunnel.org</a>>; <a href="mailto:stunnel-users@stunnel.org" target="_blank">stunnel-users@stunnel.org</a><<a href="mailto:stunnel-users@stunnel.org" target="_blank">stunnel-users@stunnel.org</a>></div>

<div><b>Subject: </b>Re: [stunnel-users] Build stunnel 4.53 binaries for windows error</div><div><br></div>I used the same openssl version: 1.0.0h<br>I had to change also CFLAGS in mingw.mak from <br>   CFLAGS=-g -O2 -Wall $(DEFINES) -I$(SSLDIR)/inc32 <br>

to<br>   CFLAGS=-g -O2 -Wall $(DEFINES) -I$(SSLDIR)/include<br>because folder inc32 doesn't exist.<br>

<br>Now when I run make -f mingw.mak I get the following error:<br># make -f mingw.mak<br>host machine is a linux machine<br>make: [makedirs] Error 1 (ignored)<br>make: [makedirs] Error 1 (ignored)<br>make: [makedirs] Error 1 (ignored)<br>



make: [makedirs] Error 1 (ignored)<br>/usr/bin/i586-mingw32msvc-gcc -g -O2 -Wall -D_WIN32_WINNT=0x0501 -I/usr/src/openssl-1.0.0h/include -o../obj/MGW32/stunnel.o -c ../src/stunnel.c<br>../src/stunnel.c:44: warning: expected [error|warning|ignored] after ‘#pragma GCC diagnostic’<br>



<b>../src/stunnel.c:47:29: error: openssl/applink.c: No such file or directory</b><br>../src/stunnel.c:49: warning: expected [error|warning|ignored] after ‘#pragma GCC diagnostic’<br>make: *** [../obj/MGW32/stunnel.o] Error 1<br>



<br>How do you configure openssl and stunnel?<br>./Configure --cross-compile-prefix=i586-mingw32msvc- mingw shared zlib-dynamic<br>and<br>./configure --with-ssl=/usr/src/openssl-1.0.0h<br>?<br><br><div class="gmail_quote">



2012/8/1 Jose Alf. <span dir="ltr"><<a href="mailto:josealf@rocketmail.com" target="_blank">josealf@rocketmail.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



<div><div style="font-size:12pt;font-family:bookman old style,new york,times,serif"><div><span>Anton,</span></div><div><span></span> </div><div><span>Actually, I managed to compile it under Debian. We were doing it wrong. We must use the same method I use under Windows :) </span></div>



<div><span>1. Go to the src directory and edit the file mingw.mak. Set variables CC, RC, RCP as needed. I attach mine for you.</span></div><div><span>2. From src, execute make -f mingw.mak</span></div><div><span>3. If everything's fine, you'll find stunnel.exe in bin/MGW32</span></div>



<div><span></span> </div><div>Time ti update the docs?</div><div>regards</div><div>Jose</div><div><br> </div>  <div style="font-family:bookman old style,new york,times,serif;font-size:12pt"> <div style="font-family:times new roman,new york,times,serif;font-size:12pt">



 <div dir="ltr"> <font face="Arial"> <div style="margin:5px 0px;padding:0px;border:1px solid rgb(204,204,204);min-height:0px;line-height:0;font-size:0px" readonly></div>  <b><span style="font-weight:bold">From:</span></b> Anton Tkachev <<a href="mailto:anton.tkachev@gmail.com" target="_blank">anton.tkachev@gmail.com</a>><br>



 <b><span style="font-weight:bold">To:</span></b> Jose Alf. <<a href="mailto:josealf@rocketmail.com" target="_blank">josealf@rocketmail.com</a>> <br><b><span style="font-weight:bold">Cc:</span></b> "<a href="mailto:stunnel-users-bounces@stunnel.org" target="_blank">stunnel-users-bounces@stunnel.org</a>" <<a href="mailto:stunnel-users-bounces@stunnel.org" target="_blank">stunnel-users-bounces@stunnel.org</a>>; "<a href="mailto:stunnel-users@stunnel.org" target="_blank">stunnel-users@stunnel.org</a>" <<a href="mailto:stunnel-users@stunnel.org" target="_blank">stunnel-users@stunnel.org</a>> <br>



 <b><span style="font-weight:bold">Sent:</span></b> Tuesday, July 31, 2012 2:39 AM<br> <b><span style="font-weight:bold">Subject:</span></b> Re: [stunnel-users] Build stunnel 4.53 binaries for windows error<br> </font> </div>



 <br>
<div>Hey Jose,<br><br>Could you just share your build inctructions under windows?<br>If it works, fine - I can use windows too :)<br><br>Thank you,<br>Anton.<br><br><div>2012/7/24 Jose Alf. <span dir="ltr"><<a href="mailto:josealf@rocketmail.com" rel="nofollow" target="_blank">josealf@rocketmail.com</a>></span><br>





<blockquote style="margin:0px 0px 0px 0.8ex;padding-left:1ex;border-left-color:rgb(204,204,204);border-left-width:1px;border-left-style:solid"><div><div style="font-family:bookman old style,new york,times,serif;font-size:12pt">



<div><span>Anton,</span></div><div>

<span></span> </div><div><span>I usually compile my stunnel under windows (mingw). I tested with Debian Squeeze installation and I found the same problem. In step 6, ./configure finish fine, but the Make step does not work.</span></div>





<div> </div><div>I checked and I found the included directories are not th right ones. I will take a look later this week.</div><div> </div><div>Mich,</div><div> </div><div>Any suggestions?<br></div><div>Regards</div><div>





Jose</div>  <div style="font-family:bookman old style,new york,times,serif;font-size:12pt"> <div style="font-family:times new roman,new york,times,serif;font-size:12pt"> <div dir="ltr"> <font face="Arial"> <div style="margin:5px 0px;padding:0px;border:1px solid rgb(204,204,204);line-height:0;font-size:0px;min-height:0px">





</div>  <b><span style="font-weight:bold">From:</span></b> Anton Tkachev <<a href="mailto:anton.tkachev@gmail.com" rel="nofollow" target="_blank">anton.tkachev@gmail.com</a>><br> <b><span style="font-weight:bold">To:</span></b> <a href="mailto:josealf@rocketmail.com" rel="nofollow" target="_blank">josealf@rocketmail.com</a> <br>





<b><span style="font-weight:bold">Cc:</span></b> <a href="mailto:stunnel-users-bounces@stunnel.org" rel="nofollow" target="_blank">stunnel-users-bounces@stunnel.org</a>; <a href="mailto:stunnel-users@stunnel.org" rel="nofollow" target="_blank">stunnel-users@stunnel.org</a> <br>





 <b><span style="font-weight:bold">Sent:</span></b> Monday, July 23, 2012 7:11 AM<br> <b><span style="font-weight:bold">Subject:</span></b> Re: [stunnel-users] Build stunnel 4.53 binaries for windows error<br> </font> </div>





 <br>
<div>> Does the  ./configure script under stunnel-4.53 finish OK?<br>Yes. No errors at this step.<br><br>> I also think that you should pass a parameter to force the cross 
compilation of stunnel. It could be using the default system compiler. 
Maybe set CC, GCC environment vars to point to the cross compiler path 
before running ./configure: eg<br>> <br> > export CC=/usr/pathtomingwgcc/bin/gcc<br>My mingw installation doesn't have any compiler.<br><br>I think the problem in openssl path, because error message is: <br># make stunnel.exe<br>







i586-mingw32msvc-gcc -c -I/usr/src/openssl-1.0.0f-i586/include -mthreads -fstack-protector -O2 -Wall -Wextra -Wno-long-long -pedantic -o str.obj str.c<br>In file included from str.c:38:<br>common.h:392:33: error: openssl/opensslconf.h: No such file or directory<br>







common.h:405:27: error: openssl/lhash.h: No such file or directory<br>common.h:406:25: error: openssl/ssl.h: No such file or directory<br>...<br><br>These files exist in /usr/src/openssl-1.0.0f-i586/include/openssl directory, but building doesn't work anyway... <br>







<br><br><div>2012/7/20  <span dir="ltr"><<a href="mailto:josealf@rocketmail.com" rel="nofollow" target="_blank">josealf@rocketmail.com</a>></span><br><blockquote style="margin:0px 0px 0px 0.8ex;padding-left:1ex;border-left-color:rgb(204,204,204);border-left-width:1px;border-left-style:solid">







<u></u><div>Anton,<br><br>Does the  ./configure script under stunnel-4.53 finish OK? I also think that you should pass a parameter to force the cross compilation of stunnel. It could be using the default system compiler. Maybe set CC, GCC environment vars to point to the cross compiler path before running ./configure: eg<br>







<br> export CC=/usr/pathtomingwgcc/bin/gcc<br><br>Enjoy!<br><div style="margin:5px 0px;padding:0px;border:1px solid rgb(204,204,204);line-height:0;font-size:0px;min-height:0px"></div><div><b>From: </b> Anton Tkachev <<a href="mailto:anton.tkachev@gmail.com" rel="nofollow" target="_blank">anton.tkachev@gmail.com</a>>
</div><div><b>Date: </b>Fri, 20 Jul 2012 21:44:09 +0700</div><div><b>To: </b><<a href="mailto:josealf@rocketmail.com" rel="nofollow" target="_blank">josealf@rocketmail.com</a>></div><div><b>Cc: </b><<a href="mailto:stunnel-users-bounces@stunnel.org" rel="nofollow" target="_blank">stunnel-users-bounces@stunnel.org</a>>; <<a href="mailto:stunnel-users@stunnel.org" rel="nofollow" target="_blank">stunnel-users@stunnel.org</a>></div>







<div><b>Subject: </b>Re: [stunnel-users] Build stunnel 4.53 binaries for windows error</div><div><div><div><br></div>Hey Jose,<br>Thank you for your response!<br><br>> You cross compiled your openssl 1.01c for mingw32, right?<br>







Yes, I used <br>./Configure --cross-compile-prefix=i586-mingw32msvc- mingw shared zlib-dynamic<br>command.<br>

<br>> Try passing the path of your mingw32 openssl includes and libs to stunnel configure:<br>
> <br>
> --with-openssl*=<br>
> <br>
> Do configure --help to see the exact syntax.<br><br>Do you mean<br>./configure --with-ssl=/usr/src/openssl-1.0.1c-i586 --includedir=/usr/i586-mingw32msvc/include --libdir=/usr/i586-mingw32msvc/lib <br>?<br>Unfortunately 'make stunnel.exe' returns the same error in this case.<br>









<br><div>2012/7/20  <span dir="ltr"><<a href="mailto:josealf@rocketmail.com" rel="nofollow" target="_blank">josealf@rocketmail.com</a>></span><br><blockquote style="margin:0px 0px 0px 0.8ex;padding-left:1ex;border-left-color:rgb(204,204,204);border-left-width:1px;border-left-style:solid">









Anton,<br>
<br>
Ahh... The joys of cross compiling!<br>
<br>
You cross compiled your openssl 1.01c for mingw32, right? Or you installed the mingw32 version.  Try passing the path of your mingw32 openssl includes and libs to stunnel configure:<br>
<br>
--with-openssl*=<br>
<br>
Do configure --help to see the exact syntax.<br>
<br>
Let us know how it goes.<br>
-----Original Message-----<br>
From: Anton Tkachev <<a href="mailto:anton.tkachev@gmail.com" rel="nofollow" target="_blank">anton.tkachev@gmail.com</a>><br>
Sender: <a href="mailto:stunnel-users-bounces@stunnel.org" rel="nofollow" target="_blank">stunnel-users-bounces@stunnel.org</a><br>
Date: Fri, 20 Jul 2012 16:28:57<br>
To: <<a href="mailto:stunnel-users@stunnel.org" rel="nofollow" target="_blank">stunnel-users@stunnel.org</a>><br>
Subject: [stunnel-users] Build stunnel 4.53 binaries for windows error<br>
<br>
_______________________________________________<br>
stunnel-users mailing list<br>
<a href="mailto:stunnel-users@stunnel.org" rel="nofollow" target="_blank">stunnel-users@stunnel.org</a><br>
<a href="http://stunnel.mirt.net/mailman/listinfo/stunnel-users" target="_blank">http://stunnel.mirt.net/mailman/listinfo/stunnel-users</a><br>
<br>
<br>
<br>
</blockquote></div><br>

</div></div></div></blockquote></div><br>
</div><br><br> </div> </div>  </div></div></blockquote></div><br>
</div><br><br> </div> </div>  </div></div></blockquote></div><br>

</div></blockquote></div><br>