Hey Guys,<br><br>I'm trying to build stunnel 4.53 binaries for windows on Debian Squeeze x86 using instructions in INSTALL.W32 file.<br>I use the latest openssl-1.0.1c (libssl-dev debian package installed also).<br>At the last step 'make stunnel.exe' returns following error:<br>

<br># make stunnel.exe<br>i586-mingw32msvc-gcc -c -I/usr/src/openssl-0.9.8s-fips/inc32 -mthreads -fstack-protector -O2 -Wall -Wextra -Wno-long-long -pedantic -o str.obj str.c<br>In file included from str.c:38:<br>common.h:392:33: error: openssl/opensslconf.h: No such file or directory<br>

common.h:405:27: error: openssl/lhash.h: No such file or directory<br>common.h:406:25: error: openssl/ssl.h: No such file or directory<br>common.h:407:25: error: openssl/err.h: No such file or directory<br>common.h:408:66: error: openssl/crypto.h: No such file or directory<br>

common.h:409:26: error: openssl/rand.h: No such file or directory<br>common.h:411:25: error: openssl/md4.h: No such file or directory<br>common.h:413:25: error: openssl/des.h: No such file or directory<br>common.h:417:28: error: openssl/engine.h: No such file or directory<br>

In file included from str.c:38:<br>common.h:449: warning: return type defaults to ‘int’<br>common.h: In function ‘STACK_OF’:<br>common.h:449: error: expected declaration specifiers before ‘*’ token<br>In file included from str.c:39:<br>

prototypes.h:50: error: storage class specified for parameter ‘LOG_MODE’<br>prototypes.h:61: error: storage class specified for parameter ‘SOCKADDR_UNION’<br>prototypes.h:64: error: expected specifier-qualifier-list before ‘SOCKADDR_UNION’<br>

prototypes.h:67: warning: struct has no members<br>prototypes.h:67: error: storage class specified for parameter ‘SOCKADDR_LIST’<br>prototypes.h:72: error: storage class specified for parameter ‘COMP_TYPE’<br>prototypes.h:78: error: expected specifier-qualifier-list before ‘COMP_TYPE’<br>

prototypes.h:114: warning: struct has no members<br>prototypes.h:114: error: storage class specified for parameter ‘GLOBAL_OPTIONS’<br>prototypes.h:116: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘global_options’<br>

prototypes.h:124: error: expected specifier-qualifier-list before ‘SSL_CTX’<br>prototypes.h:222: error: storage class specified for parameter ‘SERVICE_OPTIONS’<br>prototypes.h:224: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘service_options’<br>

prototypes.h:236: error: storage class specified for parameter ‘VAL_TYPE’<br>prototypes.h:244: error: storage class specified for parameter ‘OPT_UNION’<br>prototypes.h:250: error: expected specifier-qualifier-list before ‘VAL_TYPE’<br>

prototypes.h:252: error: storage class specified for parameter ‘SOCK_OPT’<br>prototypes.h:256: error: storage class specified for parameter ‘CONF_TYPE’<br>prototypes.h:269: error: storage class specified for parameter ‘s_poll_set’<br>

prototypes.h:278: error: storage class specified for parameter ‘DISK_FILE’<br>prototypes.h:285: error: storage class specified for parameter ‘FD’<br>prototypes.h:290: error: storage class specified for parameter ‘max_clients’<br>

prototypes.h:291: error: storage class specified for parameter ‘num_clients’<br>prototypes.h:327: warning: parameter names (without types) in function declaration<br>prototypes.h:347: error: storage class specified for parameter ‘cli_index’<br>

prototypes.h:347: error: storage class specified for parameter ‘opt_index’<br>prototypes.h:350: error: expected ‘)’ before ‘*’ token<br>prototypes.h:355: error: expected declaration specifiers or ‘...’ before ‘CONF_TYPE’<br>

prototypes.h:361: error: expected specifier-qualifier-list before ‘SERVICE_OPTIONS’<br>prototypes.h:363: warning: struct has no members<br>prototypes.h:363: error: storage class specified for parameter ‘UI_DATA’<br>prototypes.h:365: error: expected ‘)’ before ‘*’ token<br>

prototypes.h:370: error: expected ‘)’ before ‘*’ token<br>prototypes.h:374: error: expected declaration specifiers before ‘s_poll_set’<br>prototypes.h:375: error: expected ‘)’ before ‘*’ token<br>prototypes.h:376: error: expected ‘)’ before ‘*’ token<br>

prototypes.h:377: error: expected ‘)’ before ‘*’ token<br>prototypes.h:378: error: expected ‘)’ before ‘*’ token<br>prototypes.h:379: error: expected ‘)’ before ‘*’ token<br>prototypes.h:380: error: expected ‘)’ before ‘*’ token<br>

prototypes.h:381: error: expected ‘)’ before ‘*’ token<br>prototypes.h:401: error: expected specifier-qualifier-list before ‘SSL’<br>prototypes.h:422: error: storage class specified for parameter ‘CLI’<br>prototypes.h:424: error: expected declaration specifiers before ‘CLI’<br>

prototypes.h:426: error: expected ‘)’ before ‘*’ token<br>prototypes.h:430: error: expected ‘)’ before ‘*’ token<br>prototypes.h:431: error: expected ‘)’ before ‘*’ token<br>prototypes.h:432: error: expected ‘)’ before ‘*’ token<br>

prototypes.h:433: error: expected ‘)’ before ‘*’ token<br>prototypes.h:434: error: expected ‘)’ before ‘*’ token<br>prototypes.h:436: error: expected ‘)’ before ‘*’ token<br>prototypes.h:450: error: storage class specified for parameter ‘PROTOCOL_TYPE’<br>

prototypes.h:453: error: expected ‘)’ before ‘*’ token<br>prototypes.h:457: error: expected ‘)’ before ‘*’ token<br>prototypes.h:458: error: expected ‘)’ before ‘*’ token<br>prototypes.h:459: error: expected ‘)’ before ‘*’ token<br>

prototypes.h:460: error: expected ‘)’ before ‘*’ token<br>prototypes.h:461: error: expected ‘)’ before ‘*’ token<br>prototypes.h:462: warning: type defaults to ‘int’ in declaration of ‘SOCKADDR_UNION’<br>prototypes.h:462: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token<br>

prototypes.h:493: error: storage class specified for parameter ‘SECTION_CODE’<br>prototypes.h:495: warning: parameter names (without types) in function declaration<br>prototypes.h:496: warning: parameter names (without types) in function declaration<br>

prototypes.h:500: error: expected declaration specifiers or ‘...’ before ‘CLI’<br>prototypes.h:526: error: storage class specified for parameter ‘hwnd’<br>prototypes.h:530: error: expected ‘)’ before ‘*’ token<br>prototypes.h:535: error: storage class specified for parameter ‘GETADDRINFO’<br>

prototypes.h:536: error: storage class specified for parameter ‘FREEADDRINFO’<br>prototypes.h:538: error: storage class specified for parameter ‘GETNAMEINFO’<br>prototypes.h:539: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘s_getaddrinfo’<br>

prototypes.h:540: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘s_freeaddrinfo’<br>prototypes.h:541: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘s_getnameinfo’<br>prototypes.h:550: error: expected declaration specifiers before ‘DISK_FILE’<br>

prototypes.h:551: error: expected ‘)’ before ‘*’ token<br>prototypes.h:552: error: expected ‘)’ before ‘*’ token<br>prototypes.h:553: error: expected ‘)’ before ‘*’ token<br>prototypes.h:563: error: expected ‘)’ before ‘*’ token<br>

str.c:49: error: storage class specified for parameter ‘canary’<br>str.c:50: error: storage class specified for parameter ‘canary_initialized’<br>str.c:50: error: parameter ‘canary_initialized’ is initialized<br>str.c:52: error: storage class specified for parameter ‘ALLOC_LIST’<br>

str.c:55: error: expected specifier-qualifier-list before ‘ALLOC_LIST’<br>str.c:57: warning: struct has no members<br>str.c:57: error: storage class specified for parameter ‘ALLOC_TLS’<br>str.c:60: error: expected specifier-qualifier-list before ‘ALLOC_LIST’<br>

str.c:67: warning: struct has no members<br>str.c:59: warning: empty declaration<br>str.c:73: error: expected ‘)’ before ‘*’ token<br>str.c:74: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token<br>

str.c:75: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token<br>
str.c:77: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:85: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:95: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>

str.c:175: error: storage class specified for parameter ‘tls_index’<br>str.c:177: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:181: error: expected ‘)’ before ‘*’ token<br>str.c:185: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token<br>

str.c:191: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:198: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:210: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>

str.c:228: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:262: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:291: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>

str.c:315: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘{’ token<br>str.c:326: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token<br>common.h:449: warning: type of ‘SSL_COMP’ defaults to ‘int’<br>

str.c:175: error: declaration for parameter ‘tls_index’ but no such parameter<br>str.c:57: error: declaration for parameter ‘ALLOC_TLS’ but no such parameter<br>str.c:52: error: declaration for parameter ‘ALLOC_LIST’ but no such parameter<br>

str.c:50: error: declaration for parameter ‘canary_initialized’ but no such parameter<br>str.c:49: error: declaration for parameter ‘canary’ but no such parameter<br>prototypes.h:581: error: declaration for parameter ‘str_printf’ but no such parameter<br>

prototypes.h:580: error: declaration for parameter ‘str_vprintf’ but no such parameter<br>prototypes.h:579: error: declaration for parameter ‘str_dup’ but no such parameter<br>prototypes.h:577: error: declaration for parameter ‘str_free_debug’ but no such parameter<br>

prototypes.h:575: error: declaration for parameter ‘str_detach_debug’ but no such parameter<br>prototypes.h:573: error: declaration for parameter ‘str_realloc_debug’ but no such parameter<br>prototypes.h:571: error: declaration for parameter ‘str_alloc_debug’ but no such parameter<br>

prototypes.h:570: error: declaration for parameter ‘str_stats’ but no such parameter<br>prototypes.h:569: error: declaration for parameter ‘str_cleanup’ but no such parameter<br>prototypes.h:568: error: declaration for parameter ‘str_canary_init’ but no such parameter<br>

prototypes.h:567: error: declaration for parameter ‘str_init’ but no such parameter<br>prototypes.h:562: error: declaration for parameter ‘libwrap_init’ but no such parameter<br>prototypes.h:557: error: declaration for parameter ‘tstr2str’ but no such parameter<br>

prototypes.h:556: error: declaration for parameter ‘str2tstr’ but no such parameter<br>prototypes.h:537: error: declaration for parameter ‘GETNAMEINFO’ but no such parameter<br>prototypes.h:536: error: declaration for parameter ‘FREEADDRINFO’ but no such parameter<br>

prototypes.h:534: error: declaration for parameter ‘GETADDRINFO’ but no such parameter<br>prototypes.h:528: error: declaration for parameter ‘passwd_cb’ but no such parameter<br>prototypes.h:526: error: declaration for parameter ‘hwnd’ but no such parameter<br>

prototypes.h:500: error: declaration for parameter ‘create_client’ but no such parameter<br>prototypes.h:499: error: declaration for parameter ‘stunnel_thread_id’ but no such parameter<br>prototypes.h:498: error: declaration for parameter ‘stunnel_process_id’ but no such parameter<br>

prototypes.h:497: error: declaration for parameter ‘sthreads_init’ but no such parameter<br>prototypes.h:496: error: declaration for parameter ‘leave_critical_section’ but no such parameter<br>prototypes.h:495: error: declaration for parameter ‘enter_critical_section’ but no such parameter<br>

prototypes.h:493: error: declaration for parameter ‘SECTION_CODE’ but no such parameter<br>prototypes.h:479: error: declaration for parameter ‘local_getnameinfo’ but no such parameter<br>prototypes.h:463: error: declaration for parameter ‘s_gai_strerror’ but no such parameter<br>

prototypes.h:452: error: declaration for parameter ‘find_protocol_id’ but no such parameter<br>prototypes.h:450: error: declaration for parameter ‘PROTOCOL_TYPE’ but no such parameter<br>prototypes.h:425: error: declaration for parameter ‘client_thread’ but no such parameter<br>

prototypes.h:422: error: declaration for parameter ‘CLI’ but no such parameter<br>prototypes.h:395: error: declaration for parameter ‘make_sockets’ but no such parameter<br>prototypes.h:394: error: declaration for parameter ‘get_socket_error’ but no such parameter<br>

prototypes.h:393: error: declaration for parameter ‘set_socket_options’ but no such parameter<br>prototypes.h:366: error: declaration for parameter ‘sslerror’ but no such parameter<br>prototypes.h:363: error: declaration for parameter ‘UI_DATA’ but no such parameter<br>

prototypes.h:356: error: declaration for parameter ‘apply_conf’ but no such parameter<br>prototypes.h:355: error: declaration for parameter ‘parse_conf’ but no such parameter<br>prototypes.h:354: error: declaration for parameter ‘parse_commandline’ but no such parameter<br>

prototypes.h:349: error: declaration for parameter ‘ssl_init’ but no such parameter<br>prototypes.h:347: error: declaration for parameter ‘opt_index’ but no such parameter<br>prototypes.h:347: error: declaration for parameter ‘cli_index’ but no such parameter<br>

prototypes.h:343: error: declaration for parameter ‘pty_allocate’ but no such parameter<br>prototypes.h:339: error: declaration for parameter ‘s_strerror’ but no such parameter<br>prototypes.h:338: error: declaration for parameter ‘log_error’ but no such parameter<br>

prototypes.h:337: error: declaration for parameter ‘sockerror’ but no such parameter<br>prototypes.h:336: error: declaration for parameter ‘ioerror’ but no such parameter<br>prototypes.h:334: error: declaration for parameter ‘fatal_debug’ but no such parameter<br>

prototypes.h:328: error: declaration for parameter ‘s_log’ but no such parameter<br>prototypes.h:327: error: declaration for parameter ‘log_flush’ but no such parameter<br>prototypes.h:326: error: declaration for parameter ‘log_close’ but no such parameter<br>

prototypes.h:325: error: declaration for parameter ‘log_open’ but no such parameter<br>prototypes.h:317: error: declaration for parameter ‘set_nonblock’ but no such parameter<br>prototypes.h:316: error: declaration for parameter ‘s_accept’ but no such parameter<br>

prototypes.h:315: error: declaration for parameter ‘s_socketpair’ but no such parameter<br>prototypes.h:314: error: declaration for parameter ‘s_pipe’ but no such parameter<br>prototypes.h:313: error: declaration for parameter ‘s_socket’ but no such parameter<br>

prototypes.h:311: error: declaration for parameter ‘get_limits’ but no such parameter<br>prototypes.h:306: error: declaration for parameter ‘stunnel_info’ but no such parameter<br>prototypes.h:302: error: declaration for parameter ‘signal_post’ but no such parameter<br>

prototypes.h:298: error: declaration for parameter ‘bind_ports’ but no such parameter<br>prototypes.h:297: error: declaration for parameter ‘unbind_ports’ but no such parameter<br>prototypes.h:296: error: declaration for parameter ‘daemon_loop’ but no such parameter<br>

prototypes.h:295: error: declaration for parameter ‘main_configure’ but no such parameter<br>prototypes.h:294: error: declaration for parameter ‘main_initialize’ but no such parameter<br>prototypes.h:291: error: declaration for parameter ‘num_clients’ but no such parameter<br>

prototypes.h:290: error: declaration for parameter ‘max_clients’ but no such parameter<br>prototypes.h:285: error: declaration for parameter ‘FD’ but no such parameter<br>prototypes.h:278: error: declaration for parameter ‘DISK_FILE’ but no such parameter<br>

prototypes.h:269: error: declaration for parameter ‘s_poll_set’ but no such parameter<br>prototypes.h:256: error: declaration for parameter ‘CONF_TYPE’ but no such parameter<br>prototypes.h:252: error: declaration for parameter ‘SOCK_OPT’ but no such parameter<br>

prototypes.h:244: error: declaration for parameter ‘OPT_UNION’ but no such parameter<br>prototypes.h:236: error: declaration for parameter ‘VAL_TYPE’ but no such parameter<br>prototypes.h:222: error: declaration for parameter ‘SERVICE_OPTIONS’ but no such parameter<br>

prototypes.h:114: error: declaration for parameter ‘GLOBAL_OPTIONS’ but no such parameter<br>prototypes.h:72: error: declaration for parameter ‘COMP_TYPE’ but no such parameter<br>prototypes.h:67: error: declaration for parameter ‘SOCKADDR_LIST’ but no such parameter<br>

prototypes.h:61: error: declaration for parameter ‘SOCKADDR_UNION’ but no such parameter<br>prototypes.h:50: error: declaration for parameter ‘LOG_MODE’ but no such parameter<br>str.c:342: error: expected ‘{’ at end of input<br>

common.h:449: warning: unused parameter ‘SSL_COMP’<br>str.c:175: warning: unused parameter ‘tls_index’<br>str.c:57: warning: unused parameter ‘ALLOC_TLS’<br>str.c:52: warning: unused parameter ‘ALLOC_LIST’<br>str.c:50: warning: unused parameter ‘canary_initialized’<br>

str.c:49: warning: unused parameter ‘canary’<br>prototypes.h:581: warning: unused parameter ‘str_printf’<br>prototypes.h:580: warning: unused parameter ‘str_vprintf’<br>prototypes.h:579: warning: unused parameter ‘str_dup’<br>

prototypes.h:577: warning: unused parameter ‘str_free_debug’<br>prototypes.h:575: warning: unused parameter ‘str_detach_debug’<br>prototypes.h:573: warning: unused parameter ‘str_realloc_debug’<br>prototypes.h:571: warning: unused parameter ‘str_alloc_debug’<br>

prototypes.h:570: warning: unused parameter ‘str_stats’<br>prototypes.h:569: warning: unused parameter ‘str_cleanup’<br>prototypes.h:568: warning: unused parameter ‘str_canary_init’<br>prototypes.h:567: warning: unused parameter ‘str_init’<br>

prototypes.h:562: warning: unused parameter ‘libwrap_init’<br>prototypes.h:557: warning: unused parameter ‘tstr2str’<br>prototypes.h:556: warning: unused parameter ‘str2tstr’<br>prototypes.h:537: warning: unused parameter ‘GETNAMEINFO’<br>

prototypes.h:536: warning: unused parameter ‘FREEADDRINFO’<br>prototypes.h:534: warning: unused parameter ‘GETADDRINFO’<br>prototypes.h:528: warning: unused parameter ‘passwd_cb’<br>prototypes.h:526: warning: unused parameter ‘hwnd’<br>

prototypes.h:500: warning: unused parameter ‘create_client’<br>prototypes.h:499: warning: unused parameter ‘stunnel_thread_id’<br>prototypes.h:498: warning: unused parameter ‘stunnel_process_id’<br>prototypes.h:497: warning: unused parameter ‘sthreads_init’<br>

prototypes.h:496: warning: unused parameter ‘leave_critical_section’<br>prototypes.h:495: warning: unused parameter ‘enter_critical_section’<br>prototypes.h:493: warning: unused parameter ‘SECTION_CODE’<br>prototypes.h:479: warning: unused parameter ‘local_getnameinfo’<br>

prototypes.h:463: warning: unused parameter ‘s_gai_strerror’<br>prototypes.h:452: warning: unused parameter ‘find_protocol_id’<br>prototypes.h:450: warning: unused parameter ‘PROTOCOL_TYPE’<br>prototypes.h:425: warning: unused parameter ‘client_thread’<br>

prototypes.h:422: warning: unused parameter ‘CLI’<br>prototypes.h:395: warning: unused parameter ‘make_sockets’<br>prototypes.h:394: warning: unused parameter ‘get_socket_error’<br>prototypes.h:393: warning: unused parameter ‘set_socket_options’<br>

prototypes.h:366: warning: unused parameter ‘sslerror’<br>prototypes.h:363: warning: unused parameter ‘UI_DATA’<br>prototypes.h:356: warning: unused parameter ‘apply_conf’<br>prototypes.h:355: warning: unused parameter ‘parse_conf’<br>

prototypes.h:354: warning: unused parameter ‘parse_commandline’<br>prototypes.h:349: warning: unused parameter ‘ssl_init’<br>prototypes.h:347: warning: unused parameter ‘opt_index’<br>prototypes.h:347: warning: unused parameter ‘cli_index’<br>

prototypes.h:343: warning: unused parameter ‘pty_allocate’<br>prototypes.h:339: warning: unused parameter ‘s_strerror’<br>prototypes.h:338: warning: unused parameter ‘log_error’<br>prototypes.h:337: warning: unused parameter ‘sockerror’<br>

prototypes.h:336: warning: unused parameter ‘ioerror’<br>prototypes.h:334: warning: unused parameter ‘fatal_debug’<br>prototypes.h:328: warning: unused parameter ‘s_log’<br>prototypes.h:327: warning: unused parameter ‘log_flush’<br>

prototypes.h:326: warning: unused parameter ‘log_close’<br>prototypes.h:325: warning: unused parameter ‘log_open’<br>prototypes.h:317: warning: unused parameter ‘set_nonblock’<br>prototypes.h:316: warning: unused parameter ‘s_accept’<br>

prototypes.h:315: warning: unused parameter ‘s_socketpair’<br>prototypes.h:314: warning: unused parameter ‘s_pipe’<br>prototypes.h:313: warning: unused parameter ‘s_socket’<br>prototypes.h:311: warning: unused parameter ‘get_limits’<br>

prototypes.h:306: warning: unused parameter ‘stunnel_info’<br>prototypes.h:302: warning: unused parameter ‘signal_post’<br>prototypes.h:298: warning: unused parameter ‘bind_ports’<br>prototypes.h:297: warning: unused parameter ‘unbind_ports’<br>

prototypes.h:296: warning: unused parameter ‘daemon_loop’<br>prototypes.h:295: warning: unused parameter ‘main_configure’<br>prototypes.h:294: warning: unused parameter ‘main_initialize’<br>prototypes.h:291: warning: unused parameter ‘num_clients’<br>

prototypes.h:290: warning: unused parameter ‘max_clients’<br>prototypes.h:285: warning: unused parameter ‘FD’<br>prototypes.h:278: warning: unused parameter ‘DISK_FILE’<br>prototypes.h:269: warning: unused parameter ‘s_poll_set’<br>

prototypes.h:256: warning: unused parameter ‘CONF_TYPE’<br>prototypes.h:252: warning: unused parameter ‘SOCK_OPT’<br>prototypes.h:244: warning: unused parameter ‘OPT_UNION’<br>prototypes.h:236: warning: unused parameter ‘VAL_TYPE’<br>

prototypes.h:222: warning: unused parameter ‘SERVICE_OPTIONS’<br>prototypes.h:114: warning: unused parameter ‘GLOBAL_OPTIONS’<br>prototypes.h:72: warning: unused parameter ‘COMP_TYPE’<br>prototypes.h:67: warning: unused parameter ‘SOCKADDR_LIST’<br>

prototypes.h:61: warning: unused parameter ‘SOCKADDR_UNION’<br>prototypes.h:50: warning: unused parameter ‘LOG_MODE’<br>make: *** [str.obj] Error 1<br><br><br>It seems it has hardcoded path to openssl (/usr/src/openssl-0.9.8s-fips). I tried to change this path to the right one in Makefile*, but with no luck - I get the same error.<br>

<br>I also tried to build stunnel with openssl-0.9.8s, but openssl configure command from the instruction doesn't work:<br>root@debian:/usr/src/openssl-0.9.8s-i586# ./Configure --cross-compile-prefix=i586-mingw32msvc- mingw shared zlib-dynamic<br>

Usage: Configure [no-<cipher> ...] [enable-<cipher> ...] [experimental-<cipher> ...] [-Dxxx] [-lxxx] [-Lxxx] [-fxxx] [-Kxxx] [no-hw-xxx|no-hw] [[no-]threads] [[no-]shared] [[no-]zlib|zlib-dynamic] [enable-montasm] [no-asm] [no-dso] [no-krb5] [386] [--prefix=DIR] [--openssldir=OPENSSLDIR] [--with-xxx[=vvv]] [--test-sanity] os/compiler[:flags]<br>