[stunnel-users] Update on my stunnel problems

Phil Smith III phs3stuff at cox.net
Sun Jan 21 19:52:04 CET 2018

As I'm sure all of you were thinking, the localhost vs. shouldn't
have made a difference, and probably didn't: that was across two different
machines, as I'd had to switch horses mid-stream (always a bad idea, I
realize). Mind you, both machines are the same hardware, same OS, etc. And
the version started working on the first machine after a while; I
suspect I was seeing Cox's authentication server problems muddying the
waters-it has that problem from time to time.


BTW, I did check, and I have localhost entries for both IPv4 and IPv6 in my
hosts file.


This morning when I finally got access to my wife's machine, I installed
stunnel with the same config that was working on machine#2 and changed
Eudora to point to localhost. I could see Eudora happily connecting to
stunnel, but then nothing happened. After the usual checking everything, I
decided to try port 1110 instead of 110 for one of the POP accounts. That
necessitated closing and reopening Eudora so I could hack the .ini file.
After doing so, it worked.


Then I changed the other accounts to localhost and they kept working. "Odd",
sez I: "I haven't changed them to port 1110!" Still not sure how they were
working, since localhost is definitely not serving port 110 that I know of.
As my wife was getting antsy about getting her machine back, I didn't
investigate further (wish I'd had time): I just changed the stunnel port
back to 110, put the one account back to 110, restarted Eudora and refreshed
the stunnel config.and all is now working fine. So something was stuck in an
old setting, but that doesn't explain either why it was connecting to
stunnel but not getting past it, or how it was going to localhost 110 and
still working.


In any case, it's functioning beautifully (in time for the Wednesday
shutdown of non-encrypted POP), and I share this in case it helps someone
else down the line! I don't care about SMTP, as I don't use Cox's SMTP


Thanks again for all the helpful suggestions. There wasn't any single "Aha!"
moment, but they all helped lead me to the happy place.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20180121/36fbd452/attachment.html>

More information about the stunnel-users mailing list