[stunnel-users] Stunnel on Android 7.x not working?

John Appleseed paychi66 at gmail.com
Sun Oct 15 00:03:01 CEST 2017

I have trouble with stunnel on Android 7.x..
I'm trying to connect to OpenVPN server through SSL tunneling with stunnel.
On phone I'm using stunnel installed in Termux and OpenVPN. Everything is
correctly configured, Im using the same config on other devices in same
network and it works perfectly.
I tried it with different devices with Android 7.x and it is not working at
all :(

Immediately after succesful connection I am receiving:
TLS fd: Software caused connection abort (103)
TLS socket closed (SSL_read)

And it is still reconnecting again and again with the same error.
I also tried it with stunnel downloaded directly from stunnel.org site..

Anyone with new Android who have working stunnel? Where can be the problem?

Example stunnel.conf on Android:
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1
debug = debug
client = yes
accept = 1337
connect = *****.ddns.net:993
cert = /path/to/stunnel.pem

and on server:
chroot = /var/lib/stunnel4
pid    = /stunnel.pid
output = /stunnel.log
setuid = stunnel4
setgid = stunnel4
socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1
client = no
accept = 993
connect =
cert = /etc/stunnel/stunnel.pem

Example stunnel.log is in attachment.
Thank you very much
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20171015/f197c61f/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: stunnel_android_7.log
Type: text/x-log
Size: 7078 bytes
Desc: not available
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20171015/f197c61f/attachment.bin>

More information about the stunnel-users mailing list