[stunnel-users] Windows Server 2012 stunnel service

Adam Shackleton adamlives at hotmail.com
Tue Apr 18 09:36:31 CEST 2017

Hi All

I'm running stunnel on Windows Server 2012 R2 with the following config:

client = yes
accept =
connect = webaddress.com:443
cert = API-q-response.pfx
CAfile = ca-certs.pem
OCSPaia = yes

When I start the GUI I'm prompted for the certificate password then and then stunnel works fine, but I need it to run as a service. I've tried using the start menu stunnel Service Install button, I've also tried opening a command prompt in C:\Program Files (x86)\stunnel\config and running C:\Program Files (x86)\stunnel\bin\stunnel.exe -install, and I've also tried moving the config file and certs to the \bin directory and running stunnel -install there as well.

In all case the service installs ok, and when you run it, it starts (I can see it in the services tool), you can click the stunnel Configuration File Reload button in the start menu and it says the configuration was successfully reloaded, but it doesn't work when I try to use it. I've noticed two things that might be relevant:

1.       At no point does it prompt me for the certificate password like it does when I load the GUI

2.       The dialog boxes that open when the service is installed or started say "stunnel 5.40 on Win32 (not configured)

[cid:image001.png at 01D2B81E.BD3E6BC0]

If anyone has any advice that would be greatly appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20170418/3dc169fa/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 6940 bytes
Desc: image001.png
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20170418/3dc169fa/attachment.png>

More information about the stunnel-users mailing list