[stunnel-users] Can't compile stunnel 5.10 on Linux ... got fatal signal 11 error

amontaron amontaron at wanadoo.fr
Tue Feb 3 15:47:45 CET 2015

Hi again :-D

So... I compile with gcc -O1 instead of -O2 (not mentioned in INSTALL 
file anyway) and got it compiled !
There was a lot of warnings but seems to be normal ... some about 
#pragma push ... some others but it works.
I do this only for stunnel-stunnel.o/stunnel.c then for others left 
files I do normal makefile gcc -O2 ... all goes right (except for 
warnings) !
Seems good ... wanted to do "make check" to be sure ... but "nothing to 
do" each time.

Seems good but not sure at all ... should test a bit more ...

No clues ? No idea ? Also, I could stick with stunnel 3.22 sure it will 
be enough for what I need ...

Le 30/01/2015 16:45, amontaron wrote :
> Hi everybody !
>  I tried to compile stunnel 5.10 (latest) on my old Suse 7 Linux 
> distrib and got "a fatal signal 11 error message" when doing the make 
> command.
> Just before, openssl 1.0.2 (latest) compile fine with no errors.
> Also, I add some stuffs like xemacs 21.4.22 (latest) just to say that 
> that rather old distrib is able to do all that :-D
> So, here is the latest messages from make I got :
>> Making all in src
>> make[1]: Entering directory `/root/stunnel-5.10/src'
>> make  all-am
>> make[2]: Entering directory `/root/stunnel-5.10/src'
>> source='stunnel.c' object='stunnel-stunnel.o' libtool=no \
>> DEPDIR=.deps depmode=gcc /bin/sh ../auto/depcomp \
>> gcc -DHAVE_CONFIG_H -I.  -I/usr/kerberos/include 
>> -I/usr/local/ssl/include -DLIBDIR='"/usr/local/lib/stunnel"' 
>> -DCONFDIR='"/usr/local/etc/stunnel"'   -g -O2 -pthread -Wall 
>> -Wformat=2 -Wconversion -Wno-long-long -Wno-deprecated-declarations 
>> -D_FORTIFY_SOURCE=2 -c -o stunnel-stunnel.o `test -f 'stunnel.c' || 
>> echo './'`stunnel.c
>> In file included from /usr/include/string.h:346,
>>                  from common.h:201,
>>                  from stunnel.c:38:
>> /usr/include/bits/string2.h: In function `__strsep_g':
>> /usr/include/bits/string2.h:1171: warning: passing arg 2 of 
>> `__strpbrk_c2' with different width due to prototype
>> /usr/include/bits/string2.h:1171: warning: passing arg 3 of 
>> `__strpbrk_c2' with different width due to prototype
>> /usr/include/bits/string2.h:1171: warning: passing arg 2 of 
>> `__strpbrk_c3' with different width due to prototype
>> /usr/include/bits/string2.h:1171: warning: passing arg 3 of 
>> `__strpbrk_c3' with different width due to prototype
>> /usr/include/bits/string2.h:1171: warning: passing arg 4 of 
>> `__strpbrk_c3' with different width due to prototype
>> gcc: Internal compiler error: program cc1 got fatal signal 11
>> make[2]: *** [stunnel-stunnel.o] Error 1
>> make[2]: Leaving directory `/root/stunnel-5.10/src'
>> make[1]: *** [all] Error 2
>> make[1]: Leaving directory `/root/stunnel-5.10/src'
>> make: *** [all-recursive] Error 1
> Previously got lots of warning messages. Perhaps need "make report" 
> also ?
> I've look at stunnel-users at stunnel.org mail archive up to July 2011 
> with no success. So, that's why I'm writting to you there...
> Then, I tried different versions of stunnel 4.xx like 4.00, 4.56, 4.28 
> and more. All simply don't compile with differents errors messages.
> The only one I could compile completly is stunnel 3.22 (so latest 3.xx)
> Note that I'm happy with that because I was running stunnel 3.3 just 
> before and that everything works with the latest openssl version I 
> download and everything works fine for what I would !
> Remark: Suse7 distrib (not OpenSuse) is Linux 2.2.16 kernel (not 
> latest :-D)
> Alex.
> PS: Another things, on the same machine I ran stunnel 4.56 on (old) 
> Windows 98 with no problems.

Ce courrier électronique ne contient aucun virus ou logiciel malveillant parce que la protection avast! Antivirus est active.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20150203/ed7b81dd/attachment.html>

More information about the stunnel-users mailing list