[stunnel-users] Session is active but I cannot connect

daninho dj daninho.dj at gmail.com
Thu Apr 9 14:28:25 CEST 2015

Hi guys,

I am struggling with a problem for some time. I searched about this problem
in the stunnel mails archives  and also on Google but couldn't find a
solution and I ran out of ideas so I was thinking to write you about it.
I am using Eclipse to access and manipulate the data from a linux server. I
want to use stunnel when I connect to the server via Eclipse, so I
installed and configured everything as it follows:

The server I am using is SuSE Linux and the stunnel version which I
installed is this one:
*stunnel 4.27 on x86_64-suse-linux-gnu with OpenSSL 0.9.8j-fips 07 Jan 2009*

The stunnel version on Windows 7 is:
*stunnel version 5.10*

In the conf file from linux (server) I have the following configuration for

*client = no*

*chroot = /var/lib/stunnel/*
*setuid = root*
*setgid = root*

*pid = /var/run/stunnel.pid*

*debug = 7*
*output = /var/log/stunnel/stunnel.log*

*cert = /etc/ssl/certs/stunnel.pem*

*sslVersion = SSLv3*

*accept = 2404*
*connect = 2406*

In the conf file from windows (client) I have the following configuration
in stunnel.conf:

*debug = 7*
*output = C:\Program Files (x86)\stunnel\stunnel.log*

*cert = C:\Program Files (x86)\stunnel\stunnel.pem*

*sslVersion = SSLv3*

*client = yes*
*accept = <>*
*connect = xx.xxx.xxx.xxx:2406*

In the log I have this:

2015.04.09 13:48:04 LOG5[11060]: Configuration successful
2015.04.09 13:48:04 LOG7[11060]: Listening file descriptor created (FD=452)
2015.04.09 13:48:04 LOG7[11060]: Service [test] (FD=452) bound to
2015.04.09 13:48:07 LOG7[11060]: Service [test] accepted (FD=496) from
2015.04.09 13:48:07 LOG7[11060]: Creating a new thread
2015.04.09 13:48:07 LOG7[11060]: New thread created
2015.04.09 13:48:07 LOG7[2088]: Service [test] started
2015.04.09 13:48:07 LOG5[2088]: Service [test] accepted connection from
2015.04.09 13:48:07 LOG6[2088]: s_connect: connecting xx.xxx.xxx.xxx:2406
2015.04.09 13:48:07 LOG7[2088]: s_connect: s_poll_wait xx.xxx.xxx.xxx:2406:
waiting 10 seconds
2015.04.09 13:48:07 LOG5[2088]: s_connect: connected xx.xxx.xxx.xxx:2406
2015.04.09 13:48:07 LOG5[2088]: Service [test] connected remote server from
2015.04.09 13:48:07 LOG7[2088]: Remote socket (FD=516) initialized
2015.04.09 13:48:07 LOG6[2088]: SNI: sending servername: *my_server_name*
2015.04.09 13:48:07 LOG7[2088]: SSL state (connect): before/connect
2015.04.09 13:48:07 LOG7[2088]: SSL state (connect): SSLv3 write client
hello A
2015.04.09 13:48:08 LOG3[2088]: SSL_connect: Peer suddenly disconnected
2015.04.09 13:48:08 LOG5[2088]: Connection reset: 0 byte(s) sent to SSL, 0
byte(s) sent to socket
2015.04.09 13:48:08 LOG7[2088]: Remote socket (FD=516) closed
2015.04.09 13:48:08 LOG7[2088]: Local socket (FD=496) closed
2015.04.09 13:48:08 LOG7[2088]: Service [test] finished (0 left)

Although in the stunnel log it's showing *s_connect: connected* I cannot
connect at all. When I try to connect via port 2406, the stunnel icon shows
that the server is idle and I have nothing in the log about it. When I try
to connect via port 2404, the stunnel icon shows that the there are 2
active sessions but I cannot connect to the server. I tried switching the
ports (2404 with 2406 and 2406 with 2404 in the stunnel.conf file) but
stunnel doesn't even open in that case.

Do you have any idea what might could be the problem and how could I solve

Thanks in advance!

Best Regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20150409/427e812c/attachment.html>

More information about the stunnel-users mailing list