[stunnel-users] Stunnel as windows service doesn't start on restart.

John Smith java.dev.mtl at gmail.com
Fri Sep 12 19:14:46 CEST 2014


Never mind found it... Will try it and let you know :)

On 12 September 2014 13:13, John Smith <java.dev.mtl at gmail.com> wrote:

> Where is the delayed start option?
>
> On 12 September 2014 13:10, Carter Browne <cbcs at comcast.net> wrote:
>
>>  Did you select the delayed start option on the service?  I have found
>> that necessary in Windows 7/Windows server 2008 r2 and later
>>
>> Carter Brownecbrowne at cbcs-usa.com
>>
>> On 9/12/2014 12:57 PM, John Smith wrote:
>>
>>  Running stunnel 5.03 on Windows 2008 R2.
>>
>> Everything is installed and working fine. I can even start/stop the
>> service no problem... (Pretty sure the service is set to start
>> Automatically)
>>
>> When I reboot my server stunnel service shows as started but nothing gets
>> logged and none of my connections work. Once I restart the service through
>> service manager, everything works. So on startup it doesn't seem to run...
>>
>> This only happens if i reboot the machine.
>>
>>
>>  I also asked the same question here:
>> http://serverfault.com/questions/627932/stunnel-as-windows-service-doesnt-start-on-reboot
>>
>> Output of my logs proving it works.
>>
>> 2014.09.11 15:57:48 LOG5[1612]: stunnel 5.03 on x86-pc-msvc-1500 platform
>> 2014.09.11 15:57:48 LOG5[1612]: Compiled/running with OpenSSL 1.0.1i-fips 6 Aug 2014
>> 2014.09.11 15:57:48 LOG5[1612]: Threading:WIN32 Sockets:SELECT,IPv6 SSL:ENGINE,OCSP,FIPS
>> 2014.09.11 15:57:48 LOG5[1612]: Reading configuration from file stunnel.conf
>> 2014.09.11 15:57:48 LOG5[1612]: FIPS mode disabled
>> 2014.09.11 15:57:49 LOG5[1612]: Configuration successful
>>
>>
>>
>> _______________________________________________
>> stunnel-users mailing liststunnel-users at stunnel.orghttps://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users
>>
>>
>>
>> _______________________________________________
>> stunnel-users mailing list
>> stunnel-users at stunnel.org
>> https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20140912/8726d846/attachment-0001.html>


More information about the stunnel-users mailing list