[stunnel-users] capi, other engines not found at runtime

Derek Cole derek.cole at gmail.com
Fri Nov 14 23:54:13 CET 2014


I am trying to compile stunnel on windows instead of using the pre-built
binaries. When I run stunnel.exe, and have engine=capi in my stunnel.conf
file, i get the following

[ ] Enabling support for engine 'capi'
[!] error queue: 2606A074: error:2606A074:engine routines:ENGINE_by_id:no
such engine
[!] error queue: 260B6084: error:260B6084:engine routines:DYNAMIC_LOAD:dso
not found
[!] error queue: 25070067: error:25070067:DSO support
routines:DSO_load:could not load the shared library
[!] ENGINE_by_id: 25078067: error:25078067:DSO support
routines:WIN32_LOAD:could not load the shared library
[!] Line 17: "engine = capi": Failed to open the engine

Is this something wrong at link time in my compile? I used a precompiled
version of OpenSSL, and modified this:


I thought that was all that would be needed, but apparently not. I then
tried to go to make this modification:

SSLLIBS=/LIBPATH:"$(LIBDIR)" libeay32.lib ssleay32.lib capi.lib

thinking that maybe I need to explicitly add capi in, and again it
compiles, but does not run. I have also tried to move the capi.dll from the
LIBDIR into the same folder as the stunnel executable to make sure it was
found, and I still have had no luck. Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20141114/a72efb6f/attachment.html>

More information about the stunnel-users mailing list