[stunnel-users] 4.56 FIPS startup issue

Ian Donaldson iand at ekit-inc.com
Sat Mar 23 02:40:44 CET 2013

I've been using stunnel for years and tried to upgrade to 4.56 today
and it fails to start with this error:

 Clients allowed=125
stunnel 4.56 on i386-pc-solaris2.9 platform
Compiled/running with OpenSSL 1.0.1e 11 Feb 2013
Reading configuration from file /opt/local/etc/stunnel.conf
FIPS_mode_set: F06D065: error:0F06D065:common libcrypto routines:FIPS_mode_set:fips mode not supported
Line 36: "[pop3s]": Failed to initialize SSL
str_stats: 5 block(s), 118 data byte(s), 210 control byte(s)

I note some mention of FIPS in today's release.

4.55 started ok though with the same version of openssl (and crashed a few hours later), so we're back to 4.54 again.

Ian D

More information about the stunnel-users mailing list